Error when uploading experiment to Pavlovia

System: Win 10
Version: 2021.1.2
The experiment works great in the Builder mode. But when I upload my experiment to Pavlovia.ory, it came out an error like that:

Traceback (most recent call last):
File “D:\psychopy3\lib\site-packages\psychopy\app\pavlovia_ui\”, line 161, in submitChanges
self.parent.project = self.project
AttributeError: ‘NoneType’ object has no attribute ‘project’

Please give me some help.

It sounds like a temporary glitch. Try copying your essential files to a new folder, or deleting everything in your current experiment folder (including the hidden .git folder) apart from your psyexp file and your resources and try syncing again.

Best wishes,


I’ve tried what you recommended, and it didn’t work.
I’ve even create a new file that just contain only one component which is a text only, and then uploaded to Pavlovia, but still the same error.

Yeah, I have tried cleaning the project folder as well, but the same error is still there. I’m using the newest version (2021.1.3) by the way. Could this be a bug?

Hi Xinyan,

It worked when i used the version (2020.1.2), and i downloaded from the forum.
Hope it may help you.

Thank you very much! I’ll try installing that version.