psychopy.org | Reference | Downloads | Github

Trouble launching 3.0.0b6 on MacOS

MacOS 10.13.6
PsychoPy 3.0.0b6 Standard Standalone

Hi all,

I can’t make the new beta run on my Laptop, neither the Python2 nor Python3 version (while earlier betas worked fine). Double-clicking on the symbol opens a small window that crashes instantly.

I tried clearing the cache via rm -R ~/.psychopy3 , to no avail.

Running the app from command line results in:

/Applications/PsychoPy3.app/Contents/MacOS/PsychoPy3 ; exit;

Traceback (most recent call last):

File "/Applications/PsychoPy3.app/Contents/Resources/__boot__.py", line 430, in <module>

_run()

File "/Applications/PsychoPy3.app/Contents/Resources/__boot__.py", line 409, in _run

exec(compile(source, path, 'exec'), globals(), globals())

File "/Applications/PsychoPy3.app/Contents/Resources/psychopyApp.py", line 96, in <module>

start_app()

File "/Applications/PsychoPy3.app/Contents/Resources/psychopyApp.py", line 28, in start_app

app = PsychoPyApp(0, showSplash=showSplash)

File "/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/psychopy/app/_psychopyApp.py", line 178, in __init__

self.onInit(testMode=testMode, **kwargs)

File "/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/psychopy/app/_psychopyApp.py", line 212, in onInit

from psychopy.app import coder, builder, dialogs

File "/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/psychopy/app/coder/__init__.py", line 9, in <module>

from .coder import * # pylint: disable=W0401

File "/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/psychopy/app/coder/coder.py", line 22, in <module>

import psychopy.app.pavlovia_ui.menu

File "/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/psychopy/app/pavlovia_ui/__init__.py", line 22, in <module>

from . import menu, project, search, toolbar

File "/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/psychopy/app/pavlovia_ui/toolbar.py", line 4, in <module>

from .. import icons

File "/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/psychopy/app/icons.py", line 15, in <module>

from PIL import Image

File "/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/PIL/Image.py", line 64, in <module>

from . import _imaging as core

ImportError: dlopen(/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/PIL/_imaging.so, 2): Library not loaded: /usr/local/opt/jpeg/lib/libjpeg.8.dylib

Referenced from: /Applications/PsychoPy3.app/Contents/Frameworks/libtiff.5.dylib

Reason: image not found

2018-08-15 16:42:13.545 PsychoPy3[55162:591477] PsychoPy3 Error

logout

Saving session...

...copying shared history...

...saving history...truncating history files...

...completed.

Deleting expired sessions...16 completed.

Does anyone else encounter this error? Appears to be limited to the Mac, I tried the Windows version on a different computer and it started up well.

Thanks a bunch in advance.

I tried to launch it in windows but failed, the problem may also exists in windows version, I clicked on the symbol but nothing happened.

Do you get a similar error when you run PsychoPy from Commandline (not sure what the exact command in windows is)?

I don’t experience the problem on a Win 7 Desktop.

no error, but psychopy didn’t start, I use win10

I had the same issue! I don’t have a solution for you. I can confirm that installing the standalone .dmg 3.0.0b4 lets me open from Applications but the same process 3.0.0b6 does not on OS X High Sierra (10.13.4). I did notice that 3.0.0b6 has the name “PsychoPy3_PY3” unlike “PsychoPy3” like 3.0.0b4. Fingers crossed that it’s a simple patch.

Thanks guys and gals,

I’ve been able to track down some of the issues and I’ll do my best to get a new beta out today.

Mac 3.0.0b6 was indeed broken by a new way to package the Pillow (image-loading) lib. It worked fine on my machines but obviously it’s machine dependent so I’ll need to fix that.

Win 3.0.0b6 PY3 (the Py2 version was unaffected) was also broken for a different reason and that’s an easy fix that’s already implemented.

By the way, I’m planning on switching the default to be Py3. I’ll carry on building in both flavours but we’ll have:

  • PsychoPy3_PY3 becoming PsychoPy3
  • PsychoPy3 becoming PsychoPy_PY2

This reflects the fact that for most users Python3 is recommended, but Python2 still supports certain hardware that Python3 doesn’t (like labjack U-series devices)

@Felix the issue with Image that was causing your crash is now fixed in 3.0.0b7

@nickeyyyn your issue is unrelated but I have made a fix to a different problem on the Python3 version of PsychoPy3, so give 3.0.0b7 a try as well