Stuck on the "initialising the experiment" page and Sound problem

URL of the experiment:

Description of the problem: As I can see, this is a typical question, but I haven’t solved it. I posted my PsychoPy Builder study to Pavlovia, and when I go to execute the pilot, it’s just a blank screen written ‘initializing the experiment…’

The debugging page is mentioning a problem with sound, but I couldn’t fix it.
Uncaught SyntaxError: Identifier ‘sound’ has already been declared


You have a custom variable called “sound” in one of your code components, it looks like. I would name it something else.

I’ve changed the names of the sound variables, but I’m still getting the same error. Do you have any other suggestions?

Is it the exact same error? The problem is basically that there’s a line “var sound”, which is only occurring because there’s a variable called “sound” somewhere, but “sound” is already reserved for something else. When you re-sync it to Pavlovia, does it show any errors in PsychoPy’s run window?

Hi, I am having a similar issue when trying to get an experiment working on pavlovia. It is stuck on initialising experiment

It works fine when running locally in psychopy, any help or advice is mush appreciated @Jan

Hi, I’m having the same error. The error only occurs when trying to run the experiment online. Locally the experiments works just fine!