psychopy.org | Reference | Downloads | Github

Struggling with the new textboxes

URL of experiment: https://pavlovia.org/GeorgeLovell/baddeleyetal_1975

Description of the problem:

I’m trying to set up a study for a lab practical, it requires free-text entry, hence trying to use the new text boxes. It took a while to get right locally (the latest update to 2020.2.6 helped) but it still doesn’t seem to be working correctly online.

Specific problem: I need to use the same textbox in a loop so that the participant can enter five words from memory*. Currently the textboxes don’t seem to reset on each loop - as they do when run locally. After the first block the boxes don’t seem to update properly at all (so from the sixth use onwards). Finally, when run on my PC the text entry is easy, the box is the focus and I just type and press return. Online I have to click, type, press return. By then I’ve already forgotten what the words were :slight_smile:

Project files: https://www.dropbox.com/sh/oz439e9ff25rgos/AADVDSZfDMp9h_0Clv48lKdxa?dl=1

  • I tried it with 5 boxes on screen at the same time but this led to problems with focus etc.
    I’ve even taken out all the looping and just made a huge sequential experiment (it is after all only 40 words), no luck.