Online Textbox Not Working

I’m preparing an experiment to run during the spring 2022 semester that includes a forced choice component to select what picture will display to participants and routine skips depending on a participant’s answer to a question about picture details. If a participant says that they remember something different about the details of a picture than what they see in front of them, a routine with a textbox is displayed that SHOULD let them type their answer out.

The experiment runs fine locally (PsychoPy 2021.1.2), but when I upload it to Pavlovia, the textbox component will not accept any typed text at all.

Demo experiment: (please note that the problematic routine is not at the front because we have a “virtual chinrest” code that scales components like pictures and location based on screen size, so you will need to go through this first; please also note that you will need to hit “y” to get the problematic textbox routine to show, and that even though it does not accept any text, you can hit “enter” and move on to the next screen).


Some notes: this topic has previously come up multiple times 1 2 3.

Suggestions I have tried:

Any help is greatly appreciated!

Hi There,

My first highly recommended suggestion would be to upgrade to version 2021.2.3 - there really were so many improvements with taking studies online in that release and it might save a few headaches :slight_smile:


I believe the main issue with the bug is a conflict between keyboard components and editable text components.

If you aren’t able to upgrade then you might be able to replace the keyboard component with a mouse click or this code might help

Alternatively, you could use code for editable text (see my Key Check demo).

(TLDR for solution: downloaded 2021.2.3, changed from key press to mouse click which allows use of the textbox for responses, and removed html from the experiment settings to allow successful upload.)

Thank you both so much for your replies!

2021.2.3 won’t run locally on my main computer (although older versions wouldn’t either - here is my topic about that), so I am using the older install of 2021.1.2 on another computer to do most of the coding.

I downloaded 2021.2.3 to my main computer again and began trying to make changes as suggested, starting by changing the key press for a mouse click. However, this spawns another error: the upload will not load any resources, and does not even appear to be trying to.

This does not change when I clear my cookies or change browsers, and also doesn’t change when I set all of the resources to preload in PsychoPy using the settings > online tab. Once you click okay, the experiment crashes upon trying to load the first resource. This bug has been reported a few times: 1 2 3.

As far as fixing this issue, I tried recreating without html and then doing a clean upload of the experiment (duplicated the whole experiment folder and PsychoPy file and uploaded from that). Everything is now working when I upload online, including the mouse click to successfully type in the textbox. The experiment still won’t run locally but the main issue is fixed : )

Thank you both so much again!