Slider marker: it’s not visible online but it works perfectly locally

URL of experiment:

Description of the problem: I want to have a simple rating recorded at the end of each trial. I checked that Slider is the only option if I want to run the experiment online. However, my slider marker is not visible when running the experiment online. It only works when clicking from the middle and then dragging to other positions on the slider. I checked previous relevant posts, but still can’t find a solution. Does anyone know what should I do? I am using the version Psychopy 2020.2.5.

same here, only works when clicking at the exact middle position, any advice? @thomas_pronk @sotiri. ADDED: open issue

We’re not very knowledgeable of the slider component, so I relay these issues to a colleague that is. However, he only works one day per week on PsychoJS, so it can take a while before he reacts.

Thanks for your reply! Please keep us posted if there’s any progress. This would be quite annoying when running subjects online.

@YT_HAN many thanks for your patience, please bear with us a patch is on the way, x

Hello @Lu_Leng, @YT_HAN,

I believe I have just solved the issue, which had to do with us moving onto the latest version of Pixi.js, which deals with events differently from the previous version, unexpectedly.

@Lu_Leng: there are however a couple more issues with your experiment:

  • you should not use size: 1.0 when you initialise your slider. This is incorrect. I would suggest you immediately use the correct size: size: [1.0, 0.03]. Later on in BAD_ratingRoutineEachFrame, I would then remove BAD_rate.setSize([1.0, 0.03]);
  • there is an issue with the use of range in Gender_infoRoutineEnd: it should be:
var range = (start, end) => [...Array(end - start)].map((_, i) => start + i);

Best wishes,


1 Like

Dear Alain,

Thanks for your reply! I tried to implement your suggestions. However, the slider works the same as previously. I can only click at exactly the middle and drag.

Could you please help me check again?



@apitiot @sotiri @thomas_pronk Thank you all so much!! I am using 2020.2.5 and have tested on Mac: safari/chrome/firefox and on Windows: edge/chrome/firefox and it’s now fixed, the marker shows up when I click anywhere on the scale. @Lu_Leng Maybe you can try to clear the cache?

1 Like

Nice to read it’s sorted out; thanks @apitiot!

I have been using google browser all the time! Now when I switched to another browser, it worked perfectly!!! THANKS for the reminder!!!