Running into an unknown error when pilot testing

I am in the middle of pilot testing my experiment right now, gauging the stimuli. I made the experiment on psychopy and hosting it on pavlovia currently. I encountered a problem with two of my pilot tests so far. One was when giving them the link, the user brought it up on Safari, and they got an error. It was something to do with missing sound I believe, despite have no sound stimuli in the pilot study. They then reloaded the page and the experiment delayed a bit, but then started running.

The second error was a user on windows, and they tried opening it on chrome. And received the error “Unspecified JavaScript Error” and having them look at the developer tools the errors were “null core-2020.2.js:1846” and “FATAL unknown | null log4javascript.min.js:1”. I asked them to instead use firefox as opposed to chrome and it worked fine.

In addition I was unable to to get a CSV file from them. Instead it tried saving it as a CSV on their own computer.

My other concern is that I am planning using Prolific for recruitment, and while it looked simple in terms of integration with psychopy, I am worried about compatibility issues with different browsers. This is gonna be my first run with an online study, and was wondering how difficult is it in terms of compatibility.

Hi There,

For your first error:

“One was when giving them the link, the user brought it up on Safari, and they got an error. It was something to do with missing sound I believe, despite have no sound stimuli in the pilot study.”

I am guessing this was something to do with “Tone” am I right? it is most likely this is originating from a code component somewhere, but in general we recommend avoiding safari if you can ask your participants to do so, because it is a less reliable browser for experiments.

For your unspecified Javascript error there is a little fiddly fix but it should do the trick. Help with new 'Unspecified JavaScript Error' - #2 by Becca

For your last issue with the CSV it sounds like you may have shared a pilot URL instead of a running URL. be sure to switch your experiment mode from pilot to running so that you can share with participants :slight_smile:

Hope this helps,

Dear Becca,

Thank you for the help I greatly appreciate it!
In regards to Safari, that was my plan, but I was not sure if there was an easy fix for it.

As for the CSV data, I had read up a bit more and realized that pilot testing only does a local save for data files, so no worries there!

I will try out that change in the cribsheet and see if it works. I ran a few more people and none of them had that error occur.

What I have had happen though, is some of my test is not displaying correctly for instructions. I am assuming it is due to using “from experiment settings” as my units which is just “height”. Is the standard for online studies to use “pixels” as the norm? In our lab we would do degrees of freedom but can’t really control for that in online studies haha.

Best regards,


I use height online, apart from chunks of text for which I use norm.

Degrees don’t work online because you don’t have the necessary information about the participant’s monitor.

Hey Wakecarter,

So is normalized units keeping track of aspect ratios and screen dimensions? As I am assuming that is why in my instructions screen why some text was cut-off when using height as screen dimensions would be changed.


In norm units the screen is 2x2

In height units the shorter dimension of the screen is 1 but the longer dimension depends on the aspect ratio.

Height units make it easy to produce images and polygons of the desired shape. Norm units make it easy to set the text wrap width to use as much of the screen as possible.