Recreating project every time I sync to pavlovia

URL of experiment: Sign in · GitLab

Description of the problem: Hi! I had programmed an experiment with sound files that worked fine until two days ago. Now I’m getting loads of errors. I tried to uninstall and reinstall psychopy and resyncing to pavlovia and deleting everything to start afresh and now I think I just made everything worse. Every time I syncing my project to pavlovia, it asks to recreate a project and when I try to sync, it says:

When trying to the command prompt for git status(as recommended in other posts), this is what I get: ‘git’ is not recognized as an internal or external command, operable program or batch file.

I read that this is maybe because the program cannot find the path, however neither can I…
Is this normal? Should I install git separately?

Problem 2: Some parts of it also seem to be syncing with the same project but from an old account. Is there a way to fix this or wipe everything so I can start from zero starting with just the experimental file? I’m new to debugging this kind of thing and starting over is the only thing I knew how to do… :neutral_face:

If your experiment won’t sync to Gitlab, the safest way to create a new experiment on Gitlab is to duplicate your local experiment folder and then delete the hidden folder called .git from inside it. Then open the duplicate study in PsychoPy and sync as before so that it will ask to create a new project. [jon]

the git command (that can’t be found) is in the folder
You could add that to your path variable in windows to be able to access it without typing in each time.
(You could install git yourself but that shouldn’t be necssary)

I’m not sure what’s causing the error. Are you logged in as the correct user on pavlovia (RLCusiac) within PsychoPy, so when you click on the person icon you see that account as logged in?

So I tried adding that path variable following these instructions for windows 10 windows - 'git' is not recognized as an internal or external command - Stack Overflow
I copied the experiment file in a new folder and tried creating a new project
1st sync after creation
Tried experiment out on pavlovia and it’s giving me 403 Forbidden error
I installed git and restarted my computer
I tried syncing a second time
And I tried piloting again I still get 403 error

Also, when I redo git status on the command prompt, it says “On branch master nothing to commit, working tree clean”

@jon when I click on the person icon it looks as if I’m correctly logged in as RLCusiac. However, when I go to the scroll down menu (, I also see my old Username(RebekkaLC) which is weird because I deleted that old account and created this new account(RLCusiac) when things started going badly, reinstalled this new version of psychopy and never logged into the old pavlovia account on the new version of Pavlovia…

here is the new link to the experiment: Sign in · GitLab

I think I got everything to work again. For anyone who tries to uninstall and reinstall psychopy without traces of previous settings, windows has a hidden file called appdata in the C: user drive with a psychopy file in the roaming folder (Appdata>Roaming>pschopy3). Once I deleted it and reinstalled psychopy, all previously logged in usernames for pavlovia disappear. When I created a new project, exported the html and synced a second time, everything seemed to work.

I am also having this problem i.e. I upload a programme successfully to Pavlovia, all good, close programme on local machine, open it again to make changes and on trying to sync it no longer remembers the project in gitlab, so I have to delete experiment on pavlovia and start again. Deleting a couple of hidden git thing in the local folder didn’t help. Sure I can work round this, but it’s a colossal pain - anyone any suggestions?

Deleting the local git folder ensures that a new project gets created on Pavlovia.

This also happens when your local files are on a cloud drive (e.g. onedrive).

1 Like

yes but that was me trying to solve it, on basis of replies above…? the same problem when I didn’t touch the gitfiles - fails to sync with successfully uploaded experiment.

Where are your local files saved?

Hello! on my desktop.

Try a dedicated folder in My Documents.

sorry - to clarify, it is in a dedicated folder, but that’s on the desktop. can certainly try putting it in documents though (It’s a mac). thanks!

1 Like

Did you manage to solve this? I have the same problem and have always synced via the terminal as a workaround but that doesn’t seem to work any longer.