Radio button labels not aligned with scale

Hi everyone,

I have a slider (radio buttons) online for some subjective ratings in my experiment. However, when testing online, I find that the labels for the ends are not correctly aligned while in full screen:

However, when I get out of full-screen, they are okay:

This one that I have shown is a bit ugly but not a huge deal; however for some of the later scales with more ticks/labels it becomes problematic. Maybe this is a problem with resizing? Also, why are the buttons so much bigger than the text?

Hi @aisa2, what version are you using?

Are these all radios that pull questions from a conditions file, where the number of choices changes depending on the question?

If so this may be the issue addressed here (was an issue at least in 2020.2.3).
If this is the same issue, it should be fixed in 2020.2.5 now released, but I have yet to test it!

Hi @sawal, thanks for taking the time to respond.

That’s good to know about the conditions file thing, but mine is just a simple routine directly written in builder (v 2020.2.5, all up to date).

I do have a few different questions over the course of the experiment with different numbers of options, but they are each directly entered in builder, and they are in different routines. Guess we need a few more leads before this is solved. :thinking:

Hi @aisa2, hmmm odd, I wonder if it’s more general than the different numbers of options in the cond file, but instead different numbers of options for sliders however the response options are specified?

Maybe @apitiot could take a look?

1 Like

More info for anyone looking into this:

I have one radio question at the beginning of my experiment, which is the one above.
At the end of the experiment, I have a few radio questions in a loop. The first time I see each of them, their labels are misaligned, e.g.:

(after more testing, I’ve found that this happens even when not in fullscreen)

The alignment will adjust and become correct if I resize the window:

And apparently psychoPy remembers this, because in the second iteration of the loop, the labels are correct without having to resize the window:

I have noticed that this sometimes happens with buttons as well, and text, so maybe it’s not only a slider problem. The issue always resolves itself if I resize the window AFTER a routine has started, but not if it is resized before/during the onset of a routine.

Hello @aisa2,

Could you share the path to your experiment with me so I can have a look?


Here you are, it is temporarily public:

I have been running it on a Mac OS Catalina v 10.15.7 with Firefox.

Thank you. You can make it private again. I’ll get back to you shortly.

I am afraid I cannot run your experiment. I am getting multiple issues with the resources. I tried on two browsers now, with similar problems.
Could I perhaps ask you to create a smaller, sample experiment that exhibit the slider problem you mentioned? I looked into the code of your experiments but there are many, sliders there so I am not sure what to focus on.


Hello @apitiot

Thanks again for looking into this. We have indeed had some problems with resources, which I’ve posted about here, but no solution yet. I’ve found that refreshing the browser usually allows the resources to download.

Here is a simpler version, again temporarily public, where we use material from one single speaker instead of randomizing between four speakers. This will cut the size of the resources by ~75%. I have also turned off the loop for the test phase of the experiment so you don’t have to go through the entire thing to see the sliders, only the practice phase is left.

EDIT: I found this thread that seems to have a similar issue, or at least one that seems to be Mac-specific (I am also on a Mac) and for which re-sizing the window fixes things.
EDIT2: Here is another example where the screen is not updated until resizing. I’m starting to think it may be a bigger issue than just the code for sliders.

Hi, any news on this? I’m wondering if I should upgrade to 2020.2.6 to see if that fixes the problem. Otherwise, maybe it can be put on a list of bugs to fix for the next version? I’m not sure how to do that.

1 Like