| Reference | Downloads | Github

Git asking for password every time I try to push / clone

URL of experiment: (PRIVATE)

Description of the problem: I just finished coding an experiment using jspsych. I created the repository on GitLab, but when I tried to clone the project (using SSH key) I was asked for a password; "’s password: ". My Pavlovia password did not do the trick. Public SSH keys are added to the account (both RSA and the ed25519). I was also able to clone and push only 2 days ago with the same account. I tried re-creating the repository, and I also tried to push changes for a previously working existing project, ran into the exact same problem.

Any help is appreciated. Thank you!

We recently tightened security and blocked ssh access (because most people are push/pulling using https) but looks like that has caused some issues so we might open that again

I’ve just relaxed the ssh constraints. Hopefully that should solve the issue! Do let us know if you are still experiencing trouble @yarenkoca


See discussion at Push/pull commands in terminal prompt for password

We’ve relaxed the ssh constraints, at least for now. Could you check again (but also bear in mind that https is always an option too)

It seem to have worked! Thank you. I will try to stick to HTTPS from now on then.