Pavlovia ssh -T asks for password

Dear forum,

as of yesterday (?), I cannot push/ pull from my Pavlovia repos any more.

Yesterday, when tried to push/ pull/ contact the server, I used to get a permission denied warning:

$ ssh -T git@gitlab.pavlovia.org
git@gitlab.pavlovia.org: Permission denied (publickey).

I renewed & added my ssh key repeatedly, but that didn’t resolve the problem.

Today, when I try the same, I get the request to enter a password:

$ ssh -T git@gitlab.pavlovia.org
git@gitlab.pavlovia.org's password:

Could it be that Pavlovia recently changed your security settings?
I found a forum thread with the same observations from 4 years ago Git asking for password every time I try to push / clone which looks very similar???

Thanks for any help,
best regards,
Johannes

1 Like

Following, I’m having the same issue!

I also haven’t solved this issue; persisting since > 1 week (and despite multiple PC restarts)… :neutral_face: :worried: :confused:
No issues with any of the other Git hosts I’m using (Gitlab, Github).

I am running into the same issue (as well as another collaborator). @apitiot is there any chance this could be related to server security updates similar to the threads posted in the link above and also here: Push/pull commands in terminal prompt for password?

Thanks!

Stuck still and have some anxious students waiting for progress :grimacing:

Dear all,

A few words to let you know that I am investigating. This is rather bizarre and there is no obvious reasons why git would suddenly ask for the password.
Meanwhile, could I ask any of you to try and clone any of your other experiments into a fresh directory and check whether you have the same issue there?
Best wishes,

Alain

2 Likes

Thanks Alain, much appreciated!

I tried to clone one of my older studies just now (into a new folder), and am having the same issue indeed.

Did you copy the whole folder? Try making an empty local folder and then only copy into it the files you know you need.

Same issue when trying to clone using ssh into a brand new directory - the password prompt (for git@gilab.pavlovia.org's password:) pops up again when attempting to clone.

@wakecarter I’m not sure how to test out your suggestion, how do I clone just a subset of files? (or could you explain more about what you mean?)

I second, same for me: created a brand new directory on Pavlovia, tried to clone it → it asks me for a password and nothing is pulled.

What are you trying to achieve? If I want to make a copy of one of my Gitlab repositories then I fork it on Gitlab to a group (you can’t change the name when forking and you can’t have two repositories of the same name in the same namespace so I switch between Wake, vespr and brookes). Then I search for the new repository from PsychoPy and sync it to a new local folder.

Alternatively I copy the key files (skipping anything git related) locally to a new local folder and press sync to create a new repository (with a new name).

I try not to interact with Gitlab repositories directly (other than forking, adding members and viewing files). I therefore never try to “clone using ssh”. What does that try to achieve that’s different from what I’ve described above?

@wakecarter Hi! To keep things succinct, what I am trying to achieve is run jsPsych-based experiments using pavlovia following the workflow described here:

This has worked well ~4 years. As of a few weeks ago, it now no longer does, because each git command (clone, push, pull) is followed by a prompt for a password (and this is apparently not a password I have, as far as I am aware).

Let me know any suggestions you have!

Are you also using jsPsych?

I’m using it the same way as mzettersten (can’t tag yet :sweat_smile:). Building my experiments locally using jsPsych and then pushing to Gitlab.

Can you use https instead?

However, the issue is probably a more recent tightening of server security than the ones @apitiot has mentioned in previous threads. He is away this week but will hopefully be able to look into this when he gets back.

Thanks. I’ve changed the category of this thread.

A few weeks ago, the gitlab part of the service, which handles the authenticatoin side, was upgraded to a newer version and I expect this behaviour has changed as part of that upgrade.

Out of interest, do you have multifactor authentication activated for your account? I know with GitHub, if you turn on multifactor auth then you can’t use the password for git push but what you can then do is create an Access Token that allows pushing to the repository.

On Pavlovia you can create access tokens on your profile settings page

Let us know if that helps

thanks
Jon

Hi Jon,

thanks for your suggestion;
if I understand correctly, I need to create a personal access token via gitlab.pavlovia.org and then enter it instead of the password? I tried that and it didn’t work (still permission denied).
I have multifactor authentification for GitHub as well, but not for Gitlab and neither for Pavlovia as far as I am aware of—is there an option on gitlab.pavlovia.org to switch MFA on/off?

Thanks Jon! I don’t have 2FA enabled on the account, for better or for worse.

This is probably obvious but I am using SSH keys as described here (Readme · Ssh · Help · GitLab).

If ultimately it just is easiest to switch to https (which seems to work based on my initial tests so far), that is totally fine for my purposes, I just wanted to wait and see if there’s a server-related fix before re-cloning all of my existing projects/ experiments in development and updating the workflow.

Thanks!
Martin

I’ve turned 2FA off and on and off again, and tried with access tokens… no luck. Is there any chance this will be fixed any time soon? I will have to look for alternatives otherwise – I’ve ran all my projects with Pavlovia/jsPsych for the last 2 or so years, so this is a major bummer.