PsychoPy won't launch Windows 10

I hope someone can help! I am running Windows 10 and PsychoPy 2.3 was working fine until a couple of weeks ago. Now it won’t launch; there is no error code or anything. The splash screen appears and simply disappears. I’ve deleted the app data and preferences files but no luck. I don’t know anything about code (I did not create the experiment that PsychoPy is being used for; I am a technician trying to help a student who created the project in the coder version). I have uninstalled and reinstalled the standalone version but it is still not working. My computer knowledge is limited and I have tried searching the internet, but cannot find anything that is helping. I have tried opening it from the start bar and also the individual experiment file. The builder, coder and runner are all failing to open. It works fine on the student’s computer so it isn’t an issue with the file. I have also tried uninstalling recent Microsoft updates but that hasn’t helped either. I don’t know where to go next as there is not even an error code, it just doesn’t open.

Is there a log file in the %appData% folder?

There is a last_app_load file, yes

This is what the log file says:

0.0924 DEBUG Opening message catalog C:\Program Files\PsychoPy\lib\site-packages\psychopy\localization..\app\locale\en_GB\LC_MESSAGE\ for locale en_GB
0.0925 DEBUG Locale for ‘en_GB’ not found. Using default.
pygame 2.1.0 (SDL 2.0.16, Python 3.8.10)
Hello from the pygame community. Contribute - pygame wiki
Traceback (most recent call last):
File “C:\Program Files\PsychoPy\Lib\site-packages\psychopy\app\”, line 103, in
File “C:\Program Files\PsychoPy\Lib\site-packages\psychopy\app\”, line 99, in main
File “C:\Program Files\PsychoPy\Lib\site-packages\psychopy\app\”, line 27, in start_app
_ = startApp(showSplash=showSplash) # main loop
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\”, line 84, in startApp
psychopyApp = PsychoPyApp(
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\”, line 236, in init
self.onInit(testMode=testMode, **kwargs)
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\”, line 453, in onInit
from import coder, builder, runner, dialogs
File "C:\Program Files\PsychoPy\lib\site-packages\psychopy\app\coder_init
.py", line 8, in
from .coder import CoderFrame, BaseCodeEditor # pylint: disable=W0401
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\app\coder\”, line 44, in
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\app\plugin_manager\”, line 6, in
from psychopy.experiment import getAllElements
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\”, line 22, in
from .experiment import Experiment
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\”, line 32, in
from .exports import IndentingBuffer, NameSpace
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\experiment\”, line 26, in
from .components.settings import numpyImports, numpyRandomImports
File "C:\Program Files\PsychoPy\lib\site-packages\psychopy\experiment\components\settings_init
.py", line 78, in
ioDeviceMap = dict(ioUtil.getDeviceNames())
File "C:\Program Files\PsychoPy\lib\site-packages\psychopy\iohub\util_init
.py", line 389, in getDeviceNames
dconfigs = getDeviceDefaultConfig(device_name)
File "C:\Program Files\PsychoPy\lib\site-packages\psychopy\iohub\util_init
.py", line 342, in getDeviceDefaultConfig
device_paths = getDevicePaths(device_name)
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\iohub\”, line 288, in getDevicePaths
import psychopy_eyetracker_pupil_labs.pupil_labs.pupil_core as pupil_core
File “C:\Users\Psytech\AppData\Roaming\psychopy3\packages\psychopy-eyetracker-pupil-labs\”, line 14, in
from pupil_labs.real_time_screen_gaze import marker_generator
File “C:\Users\Psytech\AppData\Roaming\psychopy3\packages\psychopy-eyetracker-pupil-labs\pupil_labs\real_time_screen_gaze\”, line 3, in
apriltag_dict = cv2.aruco.getPredefinedDictionary(cv2.aruco.DICT_APRILTAG_36h11)
AttributeError: module ‘cv2’ has no attribute ‘aruco’
3.0934 DEBUG Looking for Tobii device configuration file…
3.0939 DEBUG No Tobii device configuration file found.
3.0939 DEBUG Looking for SR Research EyeLink device configuration file…
3.0943 DEBUG No SR Research EyeLink device configuration file found.
3.0943 DEBUG Looking for Gazepoint device configuration file…
3.0948 DEBUG No Gazepoint device configuration file found.
3.0948 DEBUG Looking for PupilLabs device configuration file…

The log file means nothing to me so any help would be much appreciated!

There’s a lot about eye trackers in there. Try deleting the packages folder. You’ve already tried deleting the two .cfg files in that folder, haven’t you?

I tried deleting the appData and userPrefs cfg files in the main folder, yes. Do you suggest deleting the whole packages folder? Or certain files within it? I do think this error started shortly after the student started trying to connect the experiment to the EyeLink eye tracker.

You can delete the whole folder. You may then want to reinstall some plugins, but eye trackers aren’t working well with 2023 versions.

Ok thank you. What plugins would need to be reinstalled? The student needs eye tracking for her experiment; I’m assuming that it is going to be an issue using PsychoPy for this?

For now I would recommend using 2022.2.5 if you want to use eye tracking, in which case no plug-in folder is needed

Thank you, I will try uninstalling and reinstalling the older version tomorrow.

Thank you, it is opening with the 2022.2.5 version installed