Bug Report: Issue with Syncing Experiments from Pavlovia to PsychoPy


I am currently using MacOS Ventura 13.0 and I am using PsychoPy Builder v2022.2.4. I was attempting to use the Pavlovia search function on the PsychoPy to fork and sync an experiment from the Pavlovia explore page in order to edit some of the aspects of the experiment. The forking part worked perfectly fine, but when I attempted to sync it to my local computer, I was told there was an unhandled internal error. I attempted to sync experiments I forked from the Pavlovia website on PsychoPy as well and this did not work either. I also tried to do it with multiple different experiments I have forked, but nothing worked. I wanted to put the error details here in case anyone else was experiencing these issues as well! I would appreciate any help I could get as I am new to both Pavlovia/PsychoPy and research in general, and if there is any more information I could provide, I will definitely try and find it! :slight_smile:

Error Details:
Traceback (most recent call last):
File “/Volumes/PsychoPy-2022.2.4/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/app/pavlovia_ui/project.py”, line 596, in fork
File “/Volumes/PsychoPy-2022.2.4/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/app/pavlovia_ui/project.py”, line 561, in sync
File “/Volumes/PsychoPy-2022.2.4/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/app/pavlovia_ui/project.py”, line 777, in syncProject
File “/Volumes/PsychoPy-2022.2.4/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/app/pavlovia_ui/functions.py”, line 94, in showCommitDialog
File “/Volumes/PsychoPy-2022.2.4/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/projects/pavlovia.py”, line 1058, in getChanges
File “/Volumes/PsychoPy-2022.2.4/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/projects/pavlovia.py”, line 899, in repo
File “/Volumes/PsychoPy-2022.2.4/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/projects/pavlovia.py”, line 974, in newRepo
File “/Volumes/PsychoPy-2022.2.4/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/projects/pavlovia.py”, line 1014, in cloneRepo
File “/Volumes/PsychoPy-2022.2.4/PsychoPy.app/Contents/Resources/lib/python3.8/git/repo/base.py”, line 1032, in clone_from
File “/Volumes/PsychoPy-2022.2.4/PsychoPy.app/Contents/Resources/lib/python3.8/git/repo/base.py”, line 973, in _clone
File “/Volumes/PsychoPy-2022.2.4/PsychoPy.app/Contents/Resources/lib/python3.8/git/util.py”, line 329, in finalize_process
File “/Volumes/PsychoPy-2022.2.4/PsychoPy.app/Contents/Resources/lib/python3.8/git/cmd.py”, line 408, in wait
git.exc.GitCommandError: Cmd(‘/Volumes/PsychoPy-2022.2.4/PsychoPy.app/Contents/Resources/git-core/git’) failed due to: exit code(128)
cmdline: /Volumes/PsychoPy-2022.2.4/PsychoPy.app/Contents/Resources/git-core/git clone -v Parth Nakirikanti / Blocked Stroop · GitLab /Users/parthnakirikanti/Documents
stderr: ‘fatal: destination path ‘/Users/parthnakirikanti/Documents’ already exists and is not an empty directory.

Are you trying to sync your entire documents folder?