| Reference | Downloads | Github

PsychoPy Not Responding on start

I have been trying to use PsychoPy on my main desktop PC for a while now and each time I have come to trying to fix the issue I have I find myself trawling through forums and the like which are not helping me.

I run the program and the splash image comes up with the coder view, just saying “creating frames”. The program then crashes and closes itself. I’ve done the whole cascade windows thing, it’s definitely not there. I’ve also tried to use the trouble shooting guide but there are none of the files in my roaming folder that match what was detailed on the troubleshooting page.

I have a number of other things installed on this PC, from games, to photoshop etc. I heard about DLL files maybe being a problem with this issue but I need some more technical insight.

I have got the program working on my inferior laptop, but even then I encounter some black screening when attempting to run experiments on that due to it’s age and inability to process anything (or another problem, I’m not sure). I’m running the most up to date version of Windows 10 and can post any specs you need to help me! Please help! I want to use PsychoPy on my best machine.

Hi @Bofferz, have you tried the PsychoPy troubleshooting page, in particular the section giving advice on what to do if PsychoPy does not start?

Hi @Bofferz,
I had issues on start too, it may not be the same as your problem but for me the issue was due to the Pavlovia account. I solved it (and still have to solve it sometimes) by accessing the AppData files, see thread here : Pavlovia prevents Psychopy to launch - cannot open
Hope this helps

Hi there, yes I have tried that page. The mentioned files in the AppData folder are not present and even when I remove the AppData folder I still get the same issue. Like there is something causing it to crash on startup.

The PC can definitely handle the program, it has more than enough power, so I’m not sure what the issue is on that front. Could it be some files I had installed already from other programs interfering?

Hi, thanks for the possible solution. From memory (not at the computer in question right now) I haven’t signed into Pavlovia before or built anything before installing PsychoPy. I don’t have the mentioned folder from the thread you linked.

Any other ideas?