PsychoPy experiment not syncing changes to Pavlovia

Hi everyone,

I am piloting an experiment on Pavlovia. It was working fine, but I decided I wanted to delete the demographics survey questions I had embedded into my PsychoPy experiment and just have participants complete a Qualtrics survey to get their demographics and then be directed to the experiment from there.

After deleting the demographics routines and syncing the project and then piloting it, no changes had been made despite the PsychoPy Experiment File (in the online files) having the changes made. I even tried running it in an incognito browser - same issue.

I tried deleting all the files from my local folder except for my materials and the psychopy experiment file and just re-uploading the experiment that way to Pavlovia, but when I did this, no javascript was created. I was just getting a blank window when I would try to pilot.

Any ideas on this? Thanks and really appreciate any insight.

From Troubleshooting Online Studies — PsychoPy v2022.2.4

Running the latest version of your experiment

When you synchronise changes to your experiment, you may need to clear your browser cache to see those changes online (using Ctrl-F5, Ctrl-Shift-R or equivalent). If this does not work use an incognito browser tab. A participant will not need to do this, so long as they have not already tried a previous version of your experiment.

Thanks for replying so quickly! I noted it above - but I have tried this in three different incognito browsers and the demographics questions I deleted still show up when I pilot online, despite them not showing up when running from my local files. I know the PsychPy Experiment file is updating, but it does not appear to be updating any of the other Python or Javascript files in the online experiment folder.

Any thoughts?

Sorry – you did say you’d tried an incognito tab in your first post.

I’ve just encountered a very similar issue.

I was trying to update an experiment and it wasn’t updating the online JS files, despite not showing any error messages.


Due to a bug with breaking loops early in 2022.2.x I’d set the experiment to use version 2022.1.4.

When I set this to blank I then got a synchronisation error which showed that the JS files weren’t updating. The error message lead me to discover a missing header in one of the Excel files. I was then able to reset the use version to 2022.1.4 and sync successfully.

Do you have a fixed version in Experiment Settings / General?

I didn’t have a set version originally - I tried changing it but did not see a difference.

It is tough because I didn’t build the experiment myself - I’m just adapting it to run online. I believe there is an error in the javascript somewhere because after deleting all of the files except for the psychopy experiment file and the materials (e.g., excel files), I’m stuck at ‘initializing experiment’ after uploading the study and piloting it. There is no error pointing to a line of javascript in the console - only the following comes up in the console: “Failed to load resource: the server responded with a status of 404 ()”.

Do you know of a way that I can identify the code that may be stopping it from creating the JS files so it can run online? Should I just start deleting code from the experiment until it uploads correctly to pinpoint which section of code it may be?

Thanks for all your help.

Wow… I guess I fixed it somehow. Deleted a bunch of code I didn’t need and I guess the error was in there.