Psychopy 2020.2.5 unhandled internal error

If this template helps then use it. If not then just delete and start from scratch.

OS (e.g. Win10): WIN10
PsychoPy version (e.g. 1.84.x): 2020.2.5
Standard Standalone? (y/n) If not then what?: y
**What are you trying to achieve?: Showing a text for 10 seconds

Dear All,
I have installed Psychopy version 2020.2.5, and I get an unhandled error even when trying to run a very simple exp (text appearing for 10 seconds). Any suggestion on how to solve this strange issue?
I have another PC, which is a clone of this one, and everything is working fine.

Many thanks for your help!

Here below the error:

Traceback (most recent call last):
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\runner\”, line 277, in onClose
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\runner\”, line 285, in onQuit
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\runner\”, line 545, in stopTask
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\runner\”, line 109, in stopFile
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\runner\”, line 514, in onProcessEnded
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\runner\”, line 140, in onProcessEnded
AttributeError: ‘NoneType’ object has no attribute ‘stdOut’

It looks like PsychoPy considers your Runner frame to be None, do you have the Runner window open?

We were having this problem in 2020.2.4 and I thought I’d managed to solve it, but it looks like there’s more to it. Whatever specifics you can give me would be very helpful! Could you send over your preferences file? If you go to your user folder (easiest way to find it is to go View -> Themes -> Open Theme Folder and then just go one folder up) and find the file userPrefs.cfg, that’s the one with all your preferences information in.

Many Many thanks for your prompt reply.

To give more details about my configuration:

  • Intel Core i7-3770 CPU@3.40 GHz
  • RAM 16,0Go
  • Graphic card Intel HD Graphics 4000

Here you go with the cfg file (I was not allowed to upload cfg so I changed extension) (9.8 KB) .
However, I made sure to have runner, coder and builder activated when running the experiment. I tried to (i) run it from builder and alos (ii) compile+run from coder. Both options didn’t work. The demos from builder didn’t work either, but some demos that I tried from coder were actually working.

I realized that the task was actually freezing on the initial gray screen and after around 10 mins it closed with WARINGs about frame rate. I debugged the compiled script and realized that the call win = visual.window(…) was actually causing the problem. I found this thread very useful (Sudden extreme slowing (freezing) in Windows64 (standalone install)): by manually setting the FBO option to false the experiment correctly run.

What I find extremely bizarre is that this problem happended in 4 of the 8 machines of my lab. These are all clones (hardware and softwares) and using the same screens.

I hope this could help somehow… I am still wandering what could be the cause of this variability…


Just to follow up on this, it seems that installing the 64-Bit GStreamer-1.18.0 MSVC runtime from solved the issue!


Actually, setting the FBO to “False” during the win = visual.window() call seems the only workaround to make the task working fine…