Problems with older Psychopy3 versions

I have been having problems trying to work with older versions of Psychopy3. I have tried downloading from 3.1.2, 3.2.4, and maybe one other from Github and they just throw errors whenever I try to boot up the app. I checked the troubleshooting tip regarding the preferences, but couldn’t find the files that were specified (using Mac Catalina OS).

Maybe it’s just coincidence, but when using the version 2021.1.4 and trying to run a task by specifying one of those older versions in the experiment settings, it throws an “internal error” and won’t run the task (and won’t even give any sort of feedback in the runner window). Yet when I run the task with the version specifying field left blank, it runs fine.

I can’t help but think these things are related. Ultimately, I got my task to run, but not sure what is happening regarding older versions.

Hi there, I’m having this same issue now. Did you ever find a solution? Thank you!

One easy way to get to the preferences folder is to go to View → Themes → Open themes folder from Builder in your newer install. If you go up one folder, that’s where all the preferences stuff is.