psychopy.org | Reference | Downloads | Github

Psychopy on MacOS 15.5.1

If this template helps then use it. If not then just delete and start from scratch.

OS (e.g. Win10): MacOS 15.5.1
PsychoPy version (e.g. 1.84.x): 2021.2.2
Standard Standalone? (y/n) If not then what?: y
What are you trying to achieve?: run old programs

What did you try to make it work?: run old programs

What specifically went wrong when you tried that?: black screen, then crash; no idea on how to proceed

Include pasted full error message if possible. “That didn’t work” is not enough information.

Alert 4052:Experiment was built in a past version of PsychoPy (1.81.00), saving it in this version may add parameters which cannot be parsed.
For further info see https://psychopy.org/alerts/4052.html

I’m not an expert in Psychopy. To adapt the old code, I need an advice on how to proceed since the beginning.

Many thanks, Erica

Hi There,

That sounds like it might be an issue with the experiment file itself, are there any errors in the part of the runner view labelled “Stdout”?

Thanks!
Becca