psychopy.org | Reference | Downloads | Github

Issue with psychopy 2020.1.3 installation (it goes back to v2020.1.2)

If this template helps then use it. If not then just delete and start from scratch.

OS (e.g. Win10): MacOS Catalina 10.15.6
PsychoPy version (e.g. 1.84.x): v2020.1.2
Standard Standalone? (y/n) If not then what?: yes
What are you trying to achieve?: I want to update (re-install?) v2020.1.3
What did you try to make it work?: I deleted the previous version (2020.1.2) and downloaded from the website v2020.1.3 and did the installation process as per usual (I have done this before with previous versions updates and always worked), but now when I install the standalone, after the installation is done, I open Psychopy and check the version and it is still v2020.1.2. I have done it 3 times and it is always v2020.1.2 (although the standalone says v2020.1.3).

Also I am building a current experiment now and it keeps crashing constantly. Whenever I tried to put it up online it stops working completely.

Please, help. I might be missing something here.

Screen Shot 2020-07-21 at 1.14.34 PM

I believe the Mac version simply gave the wrong version number of itself

We have a similar issue with this version of psychopy (calls itself .3, is labelled .2 on install) running on Catalina (10.15.6). The standard demos and our builder code that works elsewhere all end after the script is generated with no obvious error in the output. We’ve tried downgrading psychopy and checking the security settings to no avail.

stdout generally looks like:
Welcome …

Generating psychopy script…

##Running the experiment_lastrun.py ##
##Experiment ended ##

Any suggestions on how to get our experiments running again?

Thanks!