psychopy.org | Reference | Downloads | Github

Problem with Syncing to Pavlovia

OS: MAC OS Big Sur
PsychoPy version: created with 2021.1.2 (but asks Pavlovia to run with 2021.1.4)

What are you trying to achieve?:
I’ve been running 9 different (counterbalanced) versions of an RT experiment from PsychoPy Builder files synced to Pavlovia. I just noticed that my last two versions of the experiment seem to sync BUT they don’t change the “participant” field to “MTurk Worker ID” which was the only change made prior to syncing.

What did you try to make it work?:
In the Experiment Settings part of Builder I changed the “participant” field to “MTurk Worker ID” (without quotes). I then exported as html and synced to the existing file on Pavlovia. This exact same procedure solved the problem with all other versions of the experiment I have on Pavlovia, but not this final version.

What specifically went wrong when you tried that?:
“participant” and NOT “MTurk Worker ID” shows up in the first field when piloting the study.

I have to say that this is amongst the most frustrating programs I’ve ever worked with. There always seems to be something inexplicable going wrong even when the simplest of changes are made. I have no idea why this latest problem is surfacing, and it is critical because this is my only way to track MTurk Worker ID information that is needed on the MTurk side of things. Prior posts suggested altering some code in MTurk, but that didn’t work to preserve Worker ID information. But, in this case, doing exactly what I’ve done with 7 other Builder programs fails to work properly with this version. Apparently, the sync is working because when I ask Pavlovia to use a different version that carries through, but, strangely, the “participant” label is not changed to “MTurk Worker ID.”

Any help would be appreciated.

Hi There,

Are you sure that this is not a browser cache issue? Sometimes synced changes aren’t reflected online immediately if the browser cache needs clearing, if you clear the browser cache do the changes appear?

Thanks,
Becca

Thanks for your reply, Becca. After doing nothing overnight, I launched the pilot again the next day and all changes now appear. I didn’t clear the cache or do anything press the pilot button in Pavlovia and it now works. Every time I “think” I know what PsychoPy and Pavlovia are doing I then run into something that is strange. Although last night when I asked PsychoPy to use a different version to run, that showed up immediately in Pavlovia upon syncing but a simple change in the text field did not. Now, about 12 hours later the text field change shows up. I can imagine that there may be time delays in syncing, but for this to be totally unpredictable and highly selective is just strange and it makes life extremely difficult for the user. It makes one question what other changes, if any, may not have synced appropriately. And, how much time are we supposed to wait for the sync to really work? Frankly, I’m afraid to do anything (like clear the cache) after seeing that the experiment now works because the program seems to be so finicky.

When I started running PsychoPy online last March I almost gave up because of this issue within the first few weeks until I discovered that I could run the latest version immediately using Ctrl-Shift-R in Chrome. I doesn’t work for changes to other files (e.g. spreadsheets and embedded html) but I no longer have any issues with knowing I’m running the latest version.

At what point do you press Ctrl-Shift-R? The procedure I go through is to work locally within PsychoPy, Save, Export as html, Sync to Pavlovia (through the Globe sync to existing file button). Then, when I go to Pavlovia (with Chrome as my browser) I refresh the page and go to the experiment and click on the Pilot button. When in this process do you use the Ctrl-Shift-R command? Do I do that instead of clicking the refresh button?

Yes, either refreshing the experiment page or the actually running experiment seems to work

e.g. https://pavlovia.org/vespr/demographics or https://run.pavlovia.org/vespr/demographics

Ok, I’ll try that in the future. Thanks, much!