psychopy.org | Reference | Downloads | Github

Pilot token error Pavlovia

I keep getting the error “cannot run because the pilot token in the URL is invalid, possibly because it has expired”, whenever I try to run any of my tasks in Pavlovia. Even when I have just created the project in Pavlovia (and so the pilot token should still be valid). My co-builder is having none of these issues and is able to run our tasks perfectely fine. When I try to run the tasks this error occurs. But when he sends me the pilot link to my own study I’m able to run that task as well. There seems to be something with my account or my settings that won’t let me run my tasks online.
Any suggestions on what could be causing this?

What happens if you set the experiment to inactive and then to piloting again?

Unfortunately the same error message pops up again if I do that. It also happens if I turn it to running and back to piloting.
It doens’t seem to be related to the time a pilot token is valid, because it happens right from the beginning when I create a new experiment.

Update: I just tried creating a new account and giving myself access to the repository from the experiment that I had uploaded in my old account. However I still get the pilot token error even then.
I tried sending the link of my study to my co-designer but he also gets the pilot error when he tries to run the task then. However when he sends me the link of my study from his account I can open the task and run it.

This definitely sounds like a bug, since I’m sure that all designers should be able to pilot. Please could you take a look @jon ?

For a pilot run you need to go to the dashboard and click Pilot - the token is then created and will work just from that machine for a limited period. You can’t, for instance, forward the email to run from other machines and you can’t use that URL for a prolonged period from the same machine either.

Thanks Jon, but that’s not my experience nor what seems to be the problem here.

I have managed to occasionally get someone to pilot the study by forwarding them the pilot link (but only if they clicked it pretty much straight away). However, I’ve now switched to having a never ending final screen when showing someone else an experiment (e.g. as per my Greensleeves demo).

@Mirthe seems to only be able to pilot from someone else’s link and not their own.

Hmm, OK, maybe @apitiot relaxed the rules on being the same IP address (or possibly the computers are behind a firewall and so they appear to have the same IP!)

Can I just clarify though @Mirthe whether this happens when you press the Run button in Pavlovia dashboard. It isn’t sufficient to be in Pilotting Mode, you also have to push the button labelled Pilot to go to the experiment. (I think this is a confusing configuration to be honest and we need to rethink it)

Yes I do click the button labelled pilot as wel, but regardless of the task being in pilotting mode or running mode (and also regardless of me clicking the pilot buton or the run button) I always get the pilot token error… Even from the very first second I have uploaded a new task to Pavlovia.

Here’s a conversation between me and a student on 24th April

9:25 - Try this
https://run.pavlovia.org/Wake/ebbinghaus-darts/html/?__pilotToken=c9f0f895fb98ab9159f51fd0297e236d

9:45 - Sorry, that didn’t work either

10:04 - One more try https://run.pavlovia.org/Wake/ebbinghaus-darts/html/?__pilotToken=45c48cce2e2d7fbdea1afc51c7c6ad26

10:09 - This one works …:slight_smile: Let me go through

At 10:22 the student came back with feedback so definitely had run it.

It’s possible that she also has a Virgin Media internet connection but certainly shouldn’t have had the same IP address.

OK, so @apitiot must have loosened the requirements on the IP address (we had discusses that and I wasn’t sure it had been implemented).

I’m not sure why the Pilot button isn’t working for you though @Mirthe so we’ll need @apitiot to look into that one on the server side

@jon @apitiot Yes that would be really great! How do I request that?

Hello @Mirthe,

I just had a look and it does appear that the pilot tokens generated from your computer systematically correspond to a clock time 10h in the future (or 14h in the past). That is to say, the token generated at 23h GMT is in fact a 9h GMT, the 5h GMT token is in fact a 15h GMT. Does that make sense to you?
I just piloted your experiments on my end and can confirm that it worked, which is coherent with your observation that your experiments can be piloted by your collaborator. So my money is on a clock oddity…

Alain

EDIT: I had a collaborator in a different timezone try to pilot the experiment and it worked fine for her. It definitely seems like I am having the same issue as Mirthe. Is there a fix?

I also am experiencing a similar issue. Its unclear why I am getting the “pilot token missing” error as I am launching the experiment through clicking the “pilot” button on the experiment dashboard page and there is a pilot token present in the URL.

I’ve run through all the possible troubleshooting steps I can think of: I’ve deleted the entire project from gitlab and re-uploaded it, I’ve disabled all recently added components (the experiment was working on Pavlovia in pilot mode before I added the last few components), I also checked to see if I had any missing files in my resource folder, which I did. After making sure the necessary files had been added the resource folder, my problem was not fixed and I can’t figure out why I continue to get the “pilot token missing” error.

I do have one custom code component, however I have made sure that it is written in correct java syntax. I tested the experiment online after adding this code component and my experiment worked fine. It wasn’t until I added a few image components and one polygon component that the experiment stopped working and started throwing the pilot token error.

Thank you Alain! I was working on a Dutch laptop in a New Zealand timezone and after adjusting that I can now run all of the experiments!

You are most welcome!
@nicbo: could you check whether this is indeed a clock issue, similar to Mirthe’s?

Alain

Hi Alain,

I’ve tried setting my computer’s clock to a different timezone, but this unfortunately has not fixed my problem. I am still unable to pilot my experiment without getting the “pilot token missing” error, however my collaborator is not having any issues running the experiment. Is there another way that I should be resetting my computer’s clock?

Hi @apitiot,

I unfortunately still have not been able to fix this problem. I restarted my computer and discovered that the first time I tried pilot the experiment after restarting my computer the experiment worked, however every subsequent time I tried after that it failed and threw the “pilot token missing error.” Interestingly, even when I switched browsers (from chrome to safari) I still get the pilot token error.