psychopy.org | Reference | Downloads | Github

Pavlovia tasks stuck without error message

URL of experiment: https://run.pavlovia.org/lh628/cwt_2020-5-12/html

Description of the problem: My issue is that when I run the experiment online, it is stuck every time without an error message. This issue only occurs for this particular task and the task works perfectly offline. Sometimes, the task stops after finishing the first block (when the status is piloting) and sometimes, it stops right after the instructions (when the status is running). Any suggestions about how to solve this problem will be greatly appreciated! Thanks in advance!

Hi There,

Have you tried opening your developer tools to see if there is an error message presented in there?

Thanks,
Becca

Thank you for your reply. Yes I tried and there was no error message. So I don’t really know the reason why this happened.

What is supposed to be happening at the point that it gets stuck?

Basically, after the instruction pages, there should be a cue saying “FOOD(which is written in Chinese in the demo)” and then pictures of food (either a fruit or a vegetable).

Does the instructions page disappear?

If the food cue doesn’t appear you should check the font size, colour and position.

Sometimes, the instructions pages that have pictures of apples and the correct answer appear normally. Sometimes, the pages are stuck. The cue can appear on the screen but does not move to the next page, which is the experimental trial.

The other tasks do not have this issue.

Is there any randomisation at this point?