Pavlovia task stuck on initialising experiment page, after working without problems

URL of experiment: Pavlovia

Description of the problem: Hi, I am having a significant amount of difficulty with a study linked here that I am trying to run on pavlovia. A number of participants attempted to participate in the study and were stuck on the ‘initialising the experiment’ screen, or received an ‘unknown resource error’ (even though the requisite files were present in the repository). I will note that I attempted to pilot the task using the participants’ prolific IDs and did not encounter these errors and was able to run the task just fine.

In order to deal with this, I changed the status of the task on pavlovia from Running to Inactive and then back to Running. One of the developers on this forum– @apitiot – had suggested this to me when I was running into a similar issue in the past with a different (but related) study.

After doing this, I resent a link to a participant and they were able to run the task just fine. However the remaining 9 or so participants to whom I sent their individualized links continued to encounter the same issue––stuck on the ‘initialising the experiment’ screen.

I attempted to inactivate and reactivate the study again on pavlovia, but that has not solved the issue, and now I am experiencing the getting stuck ‘initialising the experiment’ error for piloting participants that previously worked fine for me.

I am perplexed as to why this worked for one participant and no one else, and why I was previously able to successfully pilot the task and now am unable to. Nothing in the task code has changed in weeks. Any thoughts from the developers would be extremely appreciated. This is a grant-funded study which needs to be completed within the next few months before my funding runs out and I am completely lost as to how to fix the error.

Thank you,

Hi Dominic,

Is it possible that the participants are trying a link they tried previously ? i.e. you shared a pavlovia link with them > they got an error > you fixed the project and resent them the link > they tried again

If so, perhaps ask them to clear their browser cache, I wonder if it is trying to load an older (unfixed) version of the task because their browser cached it.


Hi Becca,
Thank you for your reply. That was one of my thoughts as well; I did try that (& I tried clearing the cache on my end when I was testing things out as well), but it didn’t seem to do the trick :confused:

I was also wondering if perhaps it is an issue with the participant-facing repository on pavlovia, but I am not completely sure how I would address that aside from inactivating and reactivating the study on pavlovia.


Ask the participants to try an incognitio tab

I don’t think you changing the study to inactive and back again will have any effect.

How odd - do you also get the initialising screen? what happens when you inspect the console?

I realise it isn’t ideal but if you push a new pavlovia project with those files (i.e. copy and paste your local directory, rename the .psyexp, open it in builder and ensure to change the experiment name to match the new .psyexp in :experiment_settings: and sync :pavlovia_sync: to pavlovia) does the new link work? I ask because it really sounds like a cache thing - a new link wouldn’t have been cached for the participants.


Yes, I find it quite odd as well. I am getting this initialising screen now. Initially I was not and things were working for me, even if the participants were getting the initialising screen. But now I am getting it too. I’ve attached a screenshot of the console. I will admit I’m not totally sure what this means, or why it is occuring when nothing has changed with my code from the times when it actually worked.

As for your suggestion, this repository is actually the second one that I’ve created for this project. In other words, we did push a new pavlovia project when we encountered similar (though not the same) issue in the past and we thought we were in the clear. But now I feel as though we are back to square one. Is it possible that there is something in the cache on the pavlovia side that needs to be cleared for some reason?

I will also say that this screenshot is reflecting an error from an attempt to run a sample participant (i.e., just a test directory we have created, the resources are all present and haven’t changed) and this had also worked completely fine even when a participant-specific link was being problematic.

It looks like your task is trying to import a javascript module called dataframe.min.js was that manually added to the index.html? I think it is suggesting it needs a ‘.’ before the ‘/’ when importing that (but I don’t actually know what the dataframe.min.js refers to)