Pavlovia stuck on initialize screen

URL of experiment:

Description of the problem: I tried to run my experiment using the button on psychopy that uploads the experiment online, but for some reason it is stuck on the “initializing” screen. I had a friend upload the experiment on her computer and she is using a 3.2.3 version, but she was able to upload and run the experiment successfully. I was using the 2020.2.4 version.

I’ve been trying to see how I can download the older version of psychopy since I have no idea why it isn’t working on the 2020 version. If anyone can help either 1) fix the issue with the 2020 version or 2) help me download the older version so I can use that one, I would be very grateful!!

I would check the project activity on GitLab to see if your latest changes were successfully pushed. If so, try setting the experiment to inactive and then back to pilot again. This worked for me in the past.

I tried running your experiment, here’s the error I see on the web console.

Hi Julie,

When this error happened for me I opened the .js file (it should be in the html folder that appears in your experiment folder when you run the experiment online).

I found that opening the .js file with Rstudio (not sure if you use R?) that you can see syntax errors- denoted by a red x and if you hover over it will tell you if a bracket is missing etc. then you can alter accordingly and save the .js file

However if there is no html folder inside your experiment folder currently you will have to go into the Pyshopy builder click File/Export html.

That did the trick in my experience but there may be a more specific solution to your problem.

1 Like