Pavlovia stuck on initialising - differences in PsychoPY Version?

URL of experiment: sns_circles_eye_tracking - Copy [PsychoPy]
Project page: Sign in · GitLab
Browser: Chrome 115.0
Description of the problem:
Hi all,

I am running on PsychoPy 2023.1.3 and am trying to sync the Builder experiment to Pavlovia. The experiment can run locally, but seems to be stuck on the initialising stage when opened in a web browser. This happens regardless of the browser/computer/internet connection.

The PsychoPy file I used was developed in V2021.1.3 and it is a SAVE AS from a previous experiment that worked online flawlessly - with 99% the same code (only changed image stimuli).

In the meantime, I was receiving other errors on Pavlovia (such as “ButtonYES” is not defined, which I didnt have before).
To solve this, I thought to download the latest PsychoPY software (2023.1.3) and try with it.

With this new version, 2023.1.3), the code works locally with no issue (it’s just slower and takes longer to load, but everything works fine).


  1. How can I solve this issue and move to the actual experiment?
  2. Would this be related to the differencesin the versions of the PsychoPy?

It’s weird because before, everything worked perfectly with the same code.

Should I just downgrade the version to 2021.1.3 again?
In that case, how would I solve the issue with the “buttonYES” not defined?

Thanks in advance for your help.


Update, I solved this by downgrading PsychoPy back to 2021.1.3, but now I have the following issue:

Reference Error: buttonYES is not defined.

I receive the following errors when I get to the first screen of Pavlovia.
The buttons worked flawlessly on the previous experiment.

I even deleted the old project from Pavlovia to have everything from 0 and I still get this error.

Any ideas on how I can solve this?

Did you look at the Browser Developer console to find out the actual error?

I worked around this by downgrading to v2021.1.3, the version in which the original experiment was done.