psychopy.org | Reference | Downloads | Github

Pavlovia Help... Wrap width?


#1

URL of experiment: https://pavlovia.org/run/Sonataforce/freya_para_faces/html/

Description of the problem: There is an error that I can’t seem to work out.

The error is as such:

  • when setting the wrap width TextStim: intro
    -no default wrap width for unit: use prefs

I am trying to run it in Firefox…

I have tried playing around with the wrap width option on the advanced tab, but to no real avail. Doing so creates another error. So I thought I would start with this first, to try to understand the issue.

Sorry!

Darren


#2

Sorry, I did read the other topic on this top of error but I was still unsure…

I changed the units to ‘pix’ in experiment settings - this time, when I run the experiment online I get the error: IndexSizeError: Index or size is negative or greater than the allowed amount.


#3

More info: I tried then going into the test objects that I have used (2), and the image object (1), and changed the object size, or wrap width to something reasonable (500 pix) but still get the IndexSizeError…


#4

I don’t know if this is the cause of that error message (I’ve not seen that one before) but your letter height is definitely wrong now. You’ve got units=pix and text height=0.1 (smaller than a pixel). Conceivably that’s the issue. Could you set your text height (in each stim) and see if that fixes it?


#5

Hi Jon! Thank you so much for getting back. Yeah, so changing the text height solved the first problem. I now get the instructions, but then when I try to initiate the presentation of images I get another weird error. I think it might be to do with how it’s pulling the name of .tif image files form the conditions .xlsx file? That’s just my naive guess.

The experiment works perfectly fine running it on my Mac through the psychopy builder - it’s just the online pavlovia instance which is proving difficult (just to clarify).

So the bizarre error message is as below:

"This works perfectly fine running it on my Mac…

Unfortunately we encountered an error:

  • when setting the image of ImageStim: image
  • the argument: II*�M��%�����=�A�����R���0���|�.����=�����;���e������������������������������’������n��Ł�G��a�������x�������������������������������������7���_������������������������������/�[�u�B����c��������5���e�u���Y��������������������Z���� �����������C���������P������~������������’����������e���C�������!����������^�����T����������T���^������������������������������������������������������������&�������� �b�����������E�����D��M�����������������������������������������a�����W�q��ԕ���ց���7���O�@�܁������������!�f�����F���������C�����p����������� �����G����Q������Z�����������������,���������������������&���������=�S��������m��}���������߁�������X�{����u�������������5�������o���������������������������D�����t�����������p�����|�����܁�������������H�������������Q��������������٠��������������������������2��������������������������{������������������ĵ��К����������������3��� �������h���I�o�$������������>���������������������������9��������(����������%��G�����H�����������������r�9������_�������������������n�D��������������x����������#����������M��������E����U�7������������6�n�D�������������������������R�����3���������������r� �)�_�]�¸��(���p���:�I e-�:=HPUc@q�}
    … lots more of this and ends with ->
    �l����y�,�c���&�s%E*�7hC�O�[�g�s������p�2�_��� ���\a]�’|3-?/K is not an image" }

    ‘’

This sort of text actually repeats for many more lines but I guess we both get the gist!

Sorry if I did something stupid.


#6

TIFF isn’t really a web-friendly format. What happens if you convert your images to JPG, PNG, etc as appropriate?


#7

Hi Michael

Thank you so much for your help, yep that solved the issue!

Now I have another problem which I will try to solve first… before bugging you guys again (sorry). In a nutshell, I have put a sliding scale on (which works when running locally), but doesn’t appear when running online. I am guessing it’s a fiddle with the units - there isn’t an error code, it’s just not there.

Thanks so much

Darren


#8

(Thanks Mike) I didn’t know that about tif files! I wonder why browsers don’t like tifs!

Did you use the new Slider or the old RatingScale? RatingScale doesn’t output its code to JS, but Slider should do