| Reference | Downloads | Github

Pavlovia experiments used to work, now blank screen

URL of experiment:

Description of the problem: I had made my experiments in PsychoPy late last year, using various 2020 versions of PsychoPy. Last month or so some of them stopped running. So I copied all the files to a new folder and created copies of the experiments so I have “perky_test2” and “perky_test”, with all the same files and code, except “perky_test2” was set to a 2021 version of PsychoPy. This worked for a couple of weeks, and now the 2021 versions of my experiments are showing blank screens, and the 2020 versions are working again. What is going on? :frowning:

An added problem is that although the original (2020) versions of the experiments are working on Pavlovia, they cannot be synced/uploaded from my computer anymore (when I try to sync, it says the project does not exist). So do I just have to make a 3rd version of the experiments again using a 2020 version of PsychoPy?

When I go to I get “403 forbidden”. Maybe you need to activate it via the Pavlovia dashboard?

I just set the experiment to public (still doesn’t work with that URL I realize), so here is the link with a sample ID code from sona systems:

That’s strange; in the code I see PsychoJS 2021.1 being imported, but that version of the library doesn’t exists (all 2021 versions have the from 2021.1.x). My guess is that the steps below would solve your problem:

  1. Delete the project from Pavlovia gitlab
  2. In your psyexp file, Settings, basic tab, at Use PsychoPy version: pick the empty option
  3. In your psyexp file, Settings, basic tab, at Output Path: leave this empty (no html).
  4. Sync again

I did exactly as you suggested, but even though I leave the version blank in the settings, it defaults to 2021.1 on pavlovia.

It also defaults to 2021.1 if I choose “latest” version or “2021.1.4” instead of leaving it blank, tried both, each time deleting and recreating the project on pavlovia.

Let’s go deeper! Could you add me to your repo as a maintainer? I’m tpronk

I actually just solved it! I told a colleague about my issue, turns out he had the same problem a while ago (didn’t report it), and said removing the git-generated files from my desktop project folder would do the trick. I deleted the .git, html, and data folders, and deleted the files .gitignore and the file. Re-created the experiment and the version is now 2021.1.4, and the experiment runs!

Ah yes, the .git file. Sorry that I forgot to mention that. Regardless, happy you’re back on track!