psychopy.org | Reference | Downloads | Github

Online experiment shows a blank page only

I am using Firefix v50.1.0 and PsychoPy 1.84.2. I have created a test experiment with 1 routine that only shows a fixed text in the middle of the screen, just to see if it works. The generated HTML files indeed has JS code, but when I run it, it does nothing. No promts, no errors, no text, nothing. I have tried IE, turned of all the extensions like NoScript, yet nothing is working. Any suggests on how to solve it?

Thanks!

The test “experiment”: test.psyexp (3.2 KB)

To debug we need some kind of error messages which means you bed to open a debugging console in your browser. For Firefox instructions areally here;:

For trying to run have you followed all the instructions here:
http://www.psychopy.org/online/fromBuilder.html
?

Hello! I have the same issue as magusvulgaris. I am using PsychoPy 1.84.2
Firstly, PsychoPy exported only html file without any additional folders or so. After uploading it and the whole experiment folder the browser (checkej Edge, Firefox and Chrome) show only blank page. Nothing happens, no errors are displayed.
I checked browser’s debugger but unfortunately cannot understand what is going on there (I am not very good in coding).
Do you have an idea how to solve this issue?
Here is the link of the website: badaniefraz.pricinglab.pl
Thanks!
Aleksander

Wait, Ive just realised that both of you are using 1.84.2 and in that version the html outputs were definitely not complete. That menu item was purely to demo how things were going to work.

PsychoPy 1.85 (currently in test release phase) is the first version to include working html outputs.

Even then, these are very new a the moment and likely to contain bugs so if you aren’t very proficient with coding/debugging then I’d hold off for a while until the features get more mature.

Although this topic was one years before, I like to add some of my experience, hopefully can help someone (like I was…).
I used 1.8 version (but not 3.00b anyway) builder view builded experiment, and then I used 3.00b9 open that experiment and want to upload it and make it to be online experiment. The same problem as this topic described happened (white blank screen).
Then I re-build my experiment on the 3.00b9 environment, it works fine. So I guess, the online experiment on working when you build your whole experiment on 3.00b version. At least, that’s my experience (I was stuck there a few days before figuring it out, painfully)…

1 Like