psychopy.org | Reference | Downloads | Github

Online experiment issue: TypeError message

#1

URL of experiment: https://pavlovia.org/run/vanlou22/wordjumbler/html/

Everything runs perfectly on my home computer but this error message comes up when the study is run online:

Unfortunately we encountered an error:

  • TypeError: Cannot assign to read only property ‘undefined’ of object '#'

Try to run the experiment again. If the error persists, contact the experiment designer.

Thank you for any help in advance!

#2

HI @thisislouis, can you try removing the empty columns from your conditions files, re-sync and try again? To make sure, close your browser if it is open, before you try again.

#3

Thank you again @dvbridges! The solution worked perfectly. I cleared every column that didn’t posses either a title or content and consolidated the information so that there was no “empty” space in between the columns. Many thanks!

1 Like
#4

Hi again @dvbridges, unfortunately the problem came up again… I changed fonts (and it worked fine after that) and then added a black polygon stimulus on each slide. Would either of those have affected the TypeError message? I will continue to look at my excel sheets and see if there are any missed errors. The TypeError is the same as before and also occurs only at the first loop.

Thanks again in advance.

#5

I think it is the same error. Perhaps you have only changed the spreadsheet in your resources folder, which will have been overwritten if you synced your study. Try deleting your html folder, removing the empty columns from the conditions spreadsheet (the conditions file next to your Builder experiment file), resync to export your html and send up to Pavlovia, then, try again. Just to make sure that the correct file is being used, you could clear your cache on your browser, then close it and reopen to launch your experiment.

#6

Hey there, unfortunately this did not seem to fix the problem. I deleted the html folder, cleared the cache, and re-synced. What is strange is that when I checked the html folder online via the gitlab code, the correct files were in place too.

#7

Hmm. When I look at your trial handler, there are still empty columns being imported into the PracticeTrials loop (see undefined entries):

Have you also updated the practice sheet as well?

#8

Interesting! On my excel sheet, I have deleted and “cleared contents” of every column, cell, and row that isn’t being used. Is there another way to prevent the empty columns?

#9

Oh! I am sorry-- I was editing the ConditionsSentences page…! I see now in my Practice excel that I have blank columns. I will fix this!

#10

Excellent, I think this should fix that error.

#11

It works perfectly- the key was definitely refreshing the browser cache after the changes.

Thank you!