Online experiment doesn't load

URL of experiment: Low WM Task [PsychoPy]

Description of the problem: Hello! I have an experiment in the latest version 2022.2.1 that works perfectly offline but doesn’t load when trying to run it online through Pavlovia. I’ve attached the files here except the videos.

When using the Develop Tools, I can see the following errors:

psychojs-2022.2.1.css:1          Failed to load resource: the server responded with a status of 404 ()

psychojs-2022.2.1.js:1           Failed to load resource: the server responded with a status of 404 ()

psychojs-2022.2.1.css:1          Failed to load resource: the server responded with a status of 404 ()

I would greatly appreciate any help, advice or resources with getting it to work online!
Low WM Task.psyexp (31.1 KB)
Low WM (31.4 KB)

I think you might have created a folder called index.html in your repository.

Hi @wakecarter

Thanks for your reply. When I clicked ‘Run the study online’, it successfully synchronizes and creates the folder called index.html. I deleted this folder, but it still doesn’t work online. How do I create an online version without this index.html folder?

I would try copying the psyexp and video files to a new folder and creating a new online project. Did you at any point in the past set Experiment Settings / Online / Output path to index.html ?

Hi sorry for interrupting,

I am encountering the same problem, and I’m sure I did not change any of the settings.
Experiment Settings / Online / Output path is blank.
Psychopy automatically generated the index.html folder with js files in it.
(Here I get the error 403)

After going through other posts, I have tried a few suggetstions such as switching from inactive to piloting, which didn’t work, then I tried to move the files in the index.html folder out and deleted the folder:
スクリーンショット 2022-07-08 222643

Which worked (the experiment started running when I start it from pavlovia), but, although I’m not certain, seems to mess up other file paths, so after the first routine, it generated an error like this:

Unfortunately we encountered the following error:

  • when setting the image of ImageStim: Odd1
  • when getting the value of resource: resource/box.png
  • unknown resource

I’m not sure whether or not this is an error due to other mistakes I’ve made (I’ve tried a few solutions provided in other posts without success) or because of the above changes, but I’m at my wits end.

Hi @wakecarter

Similar to @Lan, I never set Experiment Settings / Online / Output path to index.html. I used the default which is blank.
I have copied all the video files only and recreated the .psyexp multiple times but after trying to make it run online through Pavlovia, it just never works. I do have some Python code in there which I believe may not be getting properly converted to JavaScript, but there’s no way for me to test where it is breaking. Do you have any advice?

When looking at the Experiment list on my Pavlovia account, it shows “Unknown” for the Platform and “0” for the Versions


Have you tried setting the experiment to piloting or active? It won’t run if the version is unknown, and it can’t be given a version / set to piloting or active if there is a serious JS error.

This page might help trace the error.

I have always set it to Piloting or Active when testing.

However, what made it display online with the previous version v202.1.4 was moving all the files out of the index.html folder and deleting that folder, so it shows “PsychoJS” as the Platform and '2022.1.4" int he Version, but I now get the following error when it tries to display the video:

I’m trying to understand the errors that are displayed in the Console…

How are you telling it to load the video?

Thanks for sharing the link. I did not have any of my video files listed in the Additional Resources section in the Online tab of the Experiment Settings. However, after adding all of the videos in there, as well as trying the Resource Manager Component and Static Component, all 3 options separately and 2 and 3 together, I still get the same Error message.
low (31.1 KB)
low wm.psyexp (33.5 KB)

I also converted my videos to the format suggested in the link, but is still doesn’t load the videos.

Is there anything else that could be causing this?

If you managed to try all of those variations and kept getting the same error message then I suspect that you weren’t seeing the latest version. Use Ctrl-Shift-R to flush the cache or use an incognito tab.

Hello @wakecarter

I’m not sure what exactly worked, but I deleted the online files as you suggested here "Unknown Resource" online, but works fine offline? - #10 by wakecarter and recreated the online project files after adding the videos in the Additional Resources section in the Online tab of the Experiment Settings. I also used Ctrl-Shift-R in the Project Dashboard.

Thanks a lot for your help! I greatly appreciate it :smiley:

Best wishes

1 Like