psychopy.org | Reference | Downloads | Github

Blank page when opening online experiment

URL of experiment: https://pavlovia.org/run/sabrinaa_kl/spr_final_test1/html/

Description of the problem:
Hello everyone! I wanted to upload this experiment to pavlovia and everything seemed to work fine: the files were pushed to pavlovia and everything synced. But when I start the online experiment, all I get is a blank page. There is not even an error message, so I’m even more confused. Can somebody please help me with this. I’d be really really grateful.

Kind regards,
Sabrina

I remember some other experiments having this error, check out this thread and see if any of those solutions work:

thanks! I’ve checked the thread out - I’m currently using PsychoPy 3.0.0., instead of the newest version, so that might be the problem. I’ll download the new one and see how it goes :wink:
Thanks!

@Sabrina_Klaffenbock, also, if you have an error, pressing F12 when trying to run your experiment will bring up the browser developer tools. Try this, and take a look at the console tab and see if there are any error messages.

I’ve tried starting my online experiment with the new PsychoPy version, but the problem still comes up. If I open it, I get this error message on the Avast Secure Browser:

/run/sabrinaa_kl/spr_final_test1a/html/SPR_trial.js:1 Failed to load resource: the server responded with a status of 404 ()
Tone.min.js:7 The AudioContext was not allowed to start. It must be resumed (or created) after a user gesture on the page. https://goo.gl/7K7WLu
t.Context @ Tone.min.js:7
Tone.min.js:7 * Tone.js r12 *
/run/sabrinaa_kl/spr_final_test1a/html/SPR_trial.js:1 Failed to load resource: the server responded with a status of 404 ()

and this one in Firefox:

NotSupportedError: Operation is not supported

I don’t really know what that means, so it’d be really really nice if someone could help me with this.

just wanted to say that I’ve figured out what the problem was. I’ve copied an older experiment (SPR_trial) and changed its name (to SPR_final_test1a), but whenever I tried to open it online it would search for the old version of the experiment (SPR_trial.js). That’s when I figured out that I needed to change not only the file name to the current version, but also the name in the “experiment settings” in the builder view. After I did that and synced it again, it worked.

I just wanted to post that, in case anyone had the same problem :slight_smile:

1 Like