psychopy.org | Reference | Downloads | Github

No sound offset timing (.stopped column) recorded in data file

I have a sequence of sounds presented during each trial. The times of sound offsets are not being recorded in the .stopped column of the data file for any but the last sound presented. Only “None” is recorded for the preceding sounds. In the Experiment Settings Audio tab, I have indicated 4:Latency Critical and audio library ptb. In the sound Properties, the Save onset/offset times box is checked. Any help?

OS (e.g. Win10): MacOs 10.14.6
MacBookPro, 2018
PsychoPy version (e.g. 1.84.x): 3.2.4
Standard Standalone? (y/n) y

I am having a similar issue. Though sometimes I will get a few .stopped data points randomly among the "None"s, rather than just the last one. It appears to be random and does not happen every time. I am on windows 10.