psychopy.org | Reference | Downloads | Github

Never-heard-of errors while running experiment in PsychoJS

URL of experiment: https://run.pavlovia.org/roberto.petrosino/4sa_mp/html

Description of the problem: Some of my subjects encountered two different errors while running my experiment.

  1. TypeError: this._renderer.gl is undefined
  2. TypeError: a.apply is not a function

I believe the error in (1) is connected to the already known readPixels error (see topic here), but the error in (2) is unknown, at least to me.

Does anybody know how to fix these?

Thanks!

Hi @rob-linguistics13, I had this issue above on Linux using Firefox. Apparently, Mozilla blacklist certain GPUs based on their driver number causing the webGL calls to fail, and Chrome should do something similar (article). See also mozilla issue.

We fixed this by changing the configuration settings of Firefox, as shown in the above link. The readPixels error may be solved by upgrading Chrome, but I think I solved the problem I received in Linux Chrome by changing the configuration settings to enable webGL (see here).

I know this does not help, since you cannot ask your participants to do this. But, it is some explanation for the errors.

Thanks for the clarification. I am not clear about which of the two errors you are referring to though…

This refers to the error posted above, and also to the “readPixels” error from your other post.

1 Like