psychopy.org | Reference | Downloads | Github

TypeError: Cannot read property 'readPixels' of undefined

I am trying to run my experiment online. It’s an audio discrimination task. It works perfectly on the Builder and on the Coder. But when I run the experiment online https://pavlovia.org/run/anfelaras/english-listening-task/html/, I get different errors depending on the navigator I’m using.

With Chrome, I get:
Unfortunately we encountered an error:
** TypeError: Cannot read property ‘readPixels’ of undefined *
Try to run the experiment again. If the error persists, contact the experimenter.

With Safari, the page it loads but:
Keys don’t work and the sound does not work.

Here’s a link to my project’s files, I made it public: [Andres Lara / English Listening Task · GitLab] You can run my file English_Perception.psyexp on PsychoPy to see what’s supposed to appear when I run my experiment online.

Here’s a screenshot of the error message I’m getting on chrome:
18

I tried going into the console on chrome to see what the errors were but I think it’s a problem with the underlying script and I don’t know how to fix it
32

Please help! Thank you in advance.

1 Like

Hi, I have been having the same problem. Were you able to resolve it?

Participants in the US are having the same problem with Chrome and from IExplorer they get stucked in loading the experiment… However, participants in Spain and I can run the experiment online without a problem.

https://run.pavlovia.org/karena/spanish-l2-3/html/

I’ve also had some participants in a study I ran recently receiving the “TypeError: Cannot read property ‘readPixels’ of undefined” error, but not others. For those who notified me of it, I asked for details of their browser and operating systems, and received the following replies:

Chrome 79.0.3945.130, iMac OS 10.12.6
Chrome on desktop PC
AVG secure browser and Windows
Chrome on Macbook
Chrome and Windows 7

So, it looks like it’s most common with Chrome, though that might just reflect the popularity of Chrome amongst the sample.