My experint gets stuck on initialising the experiment

URL of experiment: Sebastián Corral / Frequency-doubledgratingtaskV4 · GitLab

Description of the problem: When i upload my experiment to pavlovia, it gets stuck at initialising the experiment, but it runs well locally. I thought it has something to do with the correct answer property, because this started to happend when I enabled the “store correct” option, and it fixes when I disable it.

So i tried to download a functionally experiment to see how the script was made and I realize that, while the right answered in this experiment was write like this:

the right answer on my JS was auto-written in green, like this:

So I tried to rewrite it imitating the downloaded experiment, but when I close the coder, it goes back to where it was before I changed it.

What could i do to make the experiment to run online?


you could edit the JS-code directly, but this change will be overriden each time you change something in the experiment using the Builder.

How do you define corrAns and how do you refer to it? There is apparently an error around corrAns.

Best wishes Jens

1 Like

Thank you so much for your reply!

The first image was not taken from my experiment, I was using it as a reference from a functional experiment.

I did not realize that I could open the experiment’s JS file directly from GitLab, so I rewrite it from there, deleting the slash and asterisk in the word “right” (second image) and it worked.

Again, thank you so much for your help! :smiley: