Lib folder missing / Failed to load resources

Hi PsychoPy-World,

my experiment is currently running perfectly fine locally, but somehow the experiment is not loading online. The console tells me this:

Failed to load resource: the server responded with a status of 404 ()
Failed to load resource: the server responded with a status of 404 ()
Failed to load resource: the server responded with a status of 404 ()

I noticed that the lib folder has not been created (neither locally nor on Github).
Could this be the problem and if so how can I solve it?

I am working on a Mac with PsychoPy 2022.2.4.

Happy for any help! :slight_smile:

I’m still struggling, does anyone know what to do?

Hi katherine - could you possibly share the link to your project please?


Hi Becca,

Thank you for responding!

sure, it’s this one: Pavlovia
But it’s not public and I can’t change it to public via builder because then I get an “unhandled internal error” message.

Traceback (most recent call last):
  File „/Applications/“, line 3945, in onPavloviaProject
  File „/Applications/“, line 680, in __init__
  File „/Applications/“, line 396, in __init__
  File „/Applications/“, line 467, in project
wx._core.wxAssertionError: C++ assertion „“image.IsOk()““ failed at /Users/robind/projects/bb2/dist-osx-py38/build/ext/wxWidgets/src/osx/core/bitmap.cpp(1118) in wxBitmap(): invalid image

These are my project files, if that helps: (7.7 MB)

I already tried reinstalling PsychoPy, changing to an older PsychoPy version and syncing it from another computer, but nothing seems to work.

Hi @Becca

Do you have any idea how I can fix this problem?
I tried it with another new project with just 2 simple routines on two different computers and I still have the same problem (Failed to load resources) on both computers. I can’t open any project on Pavlovia anymore. I managed to upload on Pavlovia before, so I really don’t understand why it’s not working anymore.

This is my thesis so I am kinda scared that I have to postpone my whole study :frowning_face:


Hi Kethrin,

I just tried to sync your files from my side, I updated the Use Version option in experiment settings to 2022.2.4 to check if this works with the new release. Does this look like how you expect your experiment to run.?

I see that error you describe when trying to use the pavlovia Information :pavlovia_info: button, but I am not sure what’s causing that - I’ll share your files with our developer @TParsons who might have insight. However that shouldn’t stop your experiment running online. Please can you confirm are you syncing from a mac or windows? and are you using psychopy version 2022.2.4 ?

Best wishes,

PS. for future reference you can also change the project to public from (incase you have trouble with the pavlovia information icon as you encountered here

This line is where it tries to display the avatar for your project in the Project Info view, it looks like whatever image it’s getting back from the server is in some way malformed… If you go to your project on Pavlovia and click View Code, you can change/remove the project avatar via the Settings menu. If you remove it does it then allow you to open the info dialog?