LabJackPython Installation Issue

I am on Mac (most recent OS). I am attempting to Install LabJackPython and labjack-ljm into PsychoPy.

I am following the instructions linked above to install the two packages into PsychoPy using the terminal. (pip install package_name) It installs and gives me the following message:

“Successfully installed package_name-X.X.X”

However, I am receiving the following error message when I run the code for my experiment:

“ImportError: No module named package_name”

The code I have tried running include (each line separately):

from LabJackPython import u3

from labjack-ljm import u3

import u3

I believe it is being installed into the wrong version of Python as when I type “pip uninstall package_name” it provides the following:

Found existing installation: labjack-ljm 1.21.0

Uninstalling labjack-ljm-1.21.0:

Would remove:


However, I tried to target the correct directory using the following code and it didn’t work.

pip install labjack-ljm -t C:\djaro\Applications\\Contents\Resources\lib\python3.8

I have tried other methods of targeting the directory above without any success.

I have also followed the instructions on this page about adding custom modules to no success:

Let me know if you have any suggestions or can help! Thank you!

This is the link I am using for labjack-ljm: