psychopy.org | Reference | Downloads | Github

ioHub does not connect to Eyelink tracker

Windows 10; PsychoPy v 1.85.3;
What are you trying to achieve?:
I have successfully connected ioHub to eyelink in the past (in a different lab) but am trying to do this in a new lab with the same script (the eyetracking part is very similar to the Stroop Eyetracking Demo) and I see the following error:


What did you try to make it work?:
I have read this link (Iohub EyeLink fails to import pylink properly - #2 by andreagrant) which shows someone had a similar issue with Coder, and therefore the problem may be due to the incorrect pylink library downloaded from Psychopy 1.85.3? (I’m using Pyshcopy 1.85.3 because that’s what I used in the previous lab). I looked at the Pylink library at C:\Program Files (x86)\PsychoPy2\Lib\site-packages\psychopy\iohub\devices\eyetracker\hw\sr_research\eyelink\win32\python27
…and it did have less files than the Pylink library at C:\Program Files (x86)\SR Research\EyeLink\SampleExperiments\Python\pylink27
(the following image shows each folder side-by-side)

What happened
I moved the pylink folder from SRResearch into iohub’s pylink folder, but I still get the same error as before: Could not connect to eyetracker (see first image).

I would really appreciate any insights.
Ryan

This particular problem has now been solved. The ethernet cable from the eyetracker modem to the display modem was slightly loose (visually, it appeared connected, but it needed to be secured more firmly). A lesson to always check this before troubleshooting other possibilities.