I suspect I have a Git problem?

Hello, All

I have a few problems, but I’m going to start here.
If I try and push my project to Pavlovia from any other directory than “/Users/myusername/” I get the below error.

To circumvent this I tried to push it using git manually way back before Christmas when I was working on my dissertation project. This worked, but I am fudging my way through.

If I set the ‘create project’ setting to “/Users/myusername/” it will attempt to push 1000’s of files, and I have made the psychopy project really small to try and reverse engineer the problem. It will create an experiment in Pavlovia, but no code will be there.

Have I screwed up a git configuration somewhere along the line? I suspect so.

Many thanks for any suggestions


********Error is below:

Traceback (most recent call last):
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/app/builder/builder.py”, line 1458, in onPavloviaRun
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/app/builder/builder.py”, line 1452, in onPavloviaSync
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/app/pavlovia_ui/project.py”, line 844, in syncProject
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/app/pavlovia_ui/functions.py”, line 125, in showCommitDialog
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/projects/pavlovia.py”, line 1107, in getChanges
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/projects/pavlovia.py”, line 951, in repo
AttributeError: The requested local path for project
sits inside another folder, which git will not permit. You might like to set the project local folder to be

I think the problem is that you have a .git folder and files in /Users/myusername which you should delete before you can start using the folders correctly.

Hi, Wakefield

Thanks for the reply I will read through these and investigate.


Hi, Wakefield

Deleting the (agrhhhh, hidden) .git folder (in my AGHHHHHH user directory) fixed it.

I got lost with this, my uni library internet was stopping me connect to pavlovia and change my password so some tail chasing.

I thought “I wonder if there is a .git folder somewhere” that I didn’t know I hadn’t trashed and yes there was!

THANKYOU :slight_smile: