Psychopy Not Able to Push to Pavlovia Anymore

Version: standalone, 2021.2.3

OS: Mac Catalina 10.15.7


Recently I was having problems syncing edits on my existing psychopyprojects to pavlovia. After ruling out coding issues, it seems the issue is now widespread to every psychopy project I try. When I attempt to sync the project, Psychopy insists that I am re(creating) a project, and then hangs up, the project is never uploaded and I have to force quit to get out of Psychopy.

What I tried to make it work:
First tried deleting my projects off of pavlovia, when that didn’t work, I recreated new “test” projects with no shared features, to see if it was simply my existing projects or a universal issue. The problem persisted with new psychopy projects in new folders with new names.

I tried shutting down and restarting my computer, uninstalling, and reinstalling the same version of psychopy onto my machine. Same issue.

Thinking it might be a bug with the toolbar button, I selected run new project from the menu. This gave me the following error

Traceback (most recent call last):
File “/Applications/”, line 165, in submitChanges
File “/Applications/”, line 760, in getRepo
AttributeError: The requested local path for project
sits inside another folder, which git will not permit. You might like to set the project local folder to be

I am not sure why it would be an issue with the folder, since ALL of my experiments were kept in folders inside my general documents and USED to upload without issue. Furthermore, I am not sure why entirely new projects don’t give me the “create a project” prompt anymore – no matter what I try, it insists that I am “recreating” a project.

I do wonder if there is something amiss with my github or pavlovia account - could I have some “hidden” files that I need to delete in order to solve this issue?

I hope this is clear, happy to provide more information if it would be helpful

Is it possible that you have synced something from your documents folder which has stopped anything being synced from sub folders.

Look for a .git folder and associated files in documents.

I don’t have any .git folder in my regular documents - any psychopy files are within a subfolder in documents. Could there be another file in a different folder or a setting that somehow got changed in psychopy that caused this?

I google drive dropped all my psychopy files to a colleague who was able to upload the experiment to his gitlab just fine and run it, so the issue is definitely on my end and either my application, some corrupted file, or my gitlab account(?). Thankfully the experiment itself is not corrupted.

Are your files now in a Google drive?

The normal cause for this issue is when you have experiments files in a folder under version control (such as OneDrive, Google drive, etc.)

I sent copies of my files via google to a colleague so he could upload them only just now so my PI could look at the procedure, but I have never used drive to upload my files - I had none of these files on google at the time of the issues or any point before then.

Next idea. Are you logged into the correct account in PsychoPy? I’ve recently discovered that I occasionally seem to get logged back into the OST consultancy account (without selecting it) and have to log out and log back into my own account.

I only have one account that I know …! At least my Pavlovia account is correct when I look at what’s listed there.

Just an update, so I tried downloading the software onto my husband’s computer and pushed to pavlovia with my same account - success!

EDIT: OK I spoke too fast. The initial upload was OK, but syncing will not work anymore - I got OLD versions of my project. Is there a way to just delete my pavlovia account/gitlab account and start clean? I don’t know what else to do at this point. If I send the files to my PI he can upload directly to gitlab, but he would prefer not to do it that way, although I am not sure what else I can do honestly. Everything works fine locally. I can’t seem to find any answers.

I still receive this error:
Traceback (most recent call last):
File “/Applications/”, line 166, in submitChanges
AttributeError: ‘NoneType’ object has no attribute ‘project’

When I click “OK” it then proceeds to upload just fine, but I do wonder if whatever this is for some reason is causing the failures on my own machine.

Any ideas? Thanks!