Files replaced in gitlab do not carry over to dashboard

URL of experiment:

v 2020.2.3

browser: Chrome

Description of the problem:


I’ve manually replaced a jpg file in the experiment’s gitlab page (i.e. clicking in the file > selecting replace and uploading the newer version). The file has been properly uploaded / replaced.
When I try running the exp in the dashboard I keep on getting the older version of the jpg file.
I’ve tried erasing the cache, using another browser, as suggested in other posts… nothing. I’ve made this change about an hour ago…so I doubt it’s due to delays in pushing changes, which should be rather quick.

Is the manual replacing of files in gitlab supported in Pavlovia? Assuming it is, why is this change not being reflected in the dashboard??? Any suggestion on how to resolve this?


note: Unfortunately I cannot try pushing the file from the builder, because for some other reason the project in the builder crashed after a modification I did (the version on gitlab is the last working version)! I opened a separate topic about this crash, but I think the two things are unrelated. Psychopy Error after removing experiment info fields

Hi Nicola-
Try switching the status of your experiment (pilot->inactive->pilot). This seemed to work for me when I ran into similar issues.


Another possibility if your local copy is crashing is to try downloading the gitlab project and creating a new pavlovia project - have you tried this approach?



I had tried switching between pilot->inactive->pilot, to no avail…

I had tried replacing a file in gitlab before. Also in that instance the change took some time to carry over to the dashboard, but it was mostly a question of minutes. Not sure what causing the delay this time.

However a solution was pointed out to me regarding the crash I was experiencing in the builder (referenced in the 1st post above). I was able to push the changes via the builder and now I see the updated file, so all sorted!


pleased you found a solution!:slight_smile: