Eye Tracking ROIs not recording

If this template helps then use it. If not then just delete and start from scratch.

OS : Mac
PsychoPy version (e.g. 1.84.x): v2023.1.3

What are you trying to achieve?:
I am using a Tobii eyetracker to record gaze events. For this, I am using the roi components in the builder. In a previous experiment, this method worked just fine, however, in the current experiment the eye tracker does not start recording when the respective rois appear. The calibration procedure is working, meaning that in general the eye tracker is responsive.
I have tried changing some settings in the rois, but nothing changed.
I have also noted that when moving the roi components to the top of the builder panel, red outlines around the rois appear on the screen, but again without any response from the eye tracker.
I have multiple nested loops, so i am wondering whether that might play a role?
I’m grateful for any advice on this!

Are you starting recording via an :eyetracker_record: Eyetracker Record component? If so is it just one component set to start and stop recording or one component for each?

I am also having the same issue as the original author mentioned. I am also using Tobii Technology (Tobii Pro Fusion).

For me, I had my eyetracker turn on via code component at the end of my instructions and at the end screen of my experiment:

Even after using the eyetracker start (at end of instructions) and eyetracker stop (at the end screen) components still did not have the ROI work.

What I’m experiencing is that the ‘look at’ will not work in any form (even if looked at or with gaze on somewhere else but the ROI) and the ‘look away’ will just continue after the specified duration for a minimum look time (even if I am staring right at the ROI).

If you create a :polygon: Polygon component whose position is set each frame as eyetracker.getPos(), does it’s position line up with where your actual eyes are looking?

I am also having this issue. I downloaded a pre made eye tracking script from the following link to ensure it wasn’t user error.

The polygon attached to the cursor will change colour when inside the ROI and roi.isLookedIn is True, but roi.CurrentLookTime isn’t updated and stays at 0. I assume that the code is solid as there were no indicators otherwise in the comments.

My PsychoPy version is 2022.2.4.

Hi, I’m having the same issue, any update?

Nothing on my front, had to use a different software.

Thanks for your reply. I changed to use PsychoPy version 2023.1.1. The issue disappeared.