Eye-Tracking recording Data/ Tobii pro recording data

OS (Win11):
PsychoPy version (2022.2.4):
Standard Standalone? (y) :
Eye-Tracker: Tobii Pro X3-120

Hello all,

Today I tried to connect a Tobii Pro X3-120 eye tracker and record data. The calibration worked well and the eye tracker also starts in the routine as desired (you can see it from the infrared lights). Only where can I find the data? There is only a start and end time but no other recordings or a TSV or CSV file in which I can find the coordinates of the eyes. I know the procedure from Opensesame and there was always an extra output file.

What am I doing wrong or do I need another code component?

Thanks for your help!

You can save AOI/ROI fixation information using the beta components, but to get additional information you’ll want to save an hdf5 file (Settings > Data), and send messages for the events you want to log. E.g., at the Begin Routine

ioServer.sendMessageEvent(text=f"start_TRIAL-{trialNum_cumul}_EVENT-cue_CONDITION-{rewCond}") # start of the trial

and at End Routine

ioServer.sendMessageEvent(text=f"end_TRIAL-{trialNum_cumul}_EVENT-cue_CONDITION-{rewCond}") # end of the trial

If you do not send messages, you’ll have to write code to insert events from the psychopy csv to the hdf5, which I wouldn’t recommend. I’m happy to share a script that does this if anyone could use it.

I think we used this as a guide when we initially set up our studies. We also have a python script for reading the hdf5 and extracting events, but I can’t remember/find where it came from. Our modified script is attached.
et_proc_ttype.py (3.7 KB)

2 Likes

Dear Joseph_Orr,

Thank you very much for your help, and please excuse my late reply. Unfortunately, I did not manage to answer earlier.

It was not so easy to integrate all the needed modules in Python. Windows 11 makes it a bit harder than Linux or Mac OS. But I was able to find a solution after long research. Now I have the following problem… Line 7:

file = sys.argv[1]

gives me an error message that I can’t quite explain yet:

IndexError: list index out of range

Unfortunately, I can’t manage to deal with it anymore this week. However, if you happen to know where the problem lies, I would be very grateful if you could give me a hint.

Kind regards