psychopy.org | Reference | Downloads | Github

Experiment won't run, monitor calibration issue?

Running standalone 2021.2.3 on MacOS (Big Sur 11.5.2).

Every time I try to run an experiment, I get this output in the runner:

2333.1025 INFO Loaded monitor calibration from [‘2021_07_19 13:50’]

I’ve tried uninstalling and re-installing PsychoPy and testing different experiment files, all with the same result. Things were working fine yesterday and I don’t think I’ve touched any settings, I’m not sure what happened.

After looking at similar issues, I’ve tried setting up a new monitor in settings, but that doesn’t seem to be working.

Also wondering how screen size gets handled when publishing an experiment online with Pavlovia - do the experiments automatically get scaled to the different monitor sizes of the participants?

Any help is greatly appreciated!

Hi There,

This message is an INFO rather than ERROR message - so it shouldn’t stop the experiment running - are you able do run any of the experiments in the demos dropdown of builder?

Thanks,
Becca

No, I still get the same issue with the demos.

OK that sounds like something else is happening. So that we can check if this is specific to builderview please can you select window > coder > then try one of the demos there to see if they run.

For your other question about screen scaling, it will depend on the unit you use. If you use the default unit (height) all stimuli will be scaled proportionally to the screen size i.e. stimuli will appear as the same proportion of the window across devices, but they will not be the same physical size in cm (there are ways of doing that using the screen scaling demo)

Becca

Hi Becca,

It seems to works fine when using the coder, just not the builder.

And thank you for the answer re: scaling!

I’m having the same issue.
Did you manage to make the experiment run?

Yes, using the coder worked for a while. When that stopped working, I found using the “Run experiment” button rather than the “Send experiment to runner” button worked in the Builder.

Hi There,

Please may you confirm if you are also on big sur?

If you get any error messages please can you share those? If inside builder your use experiment settings > use version and use a previous version does that work?

Thanks,
Becca

Hi,
I was not on big sur.
I didn’t get any error messages and I actually solved it by changing the audio preferences.

Changing the audio preferences? That’s interesting. Do you recall what you changed from/to? If other people have this issue please also chime in - if there’s something specific we can change/fix to prevent others having the problem that would be great (up until then there wasn’t much to go on!)