Experiment visible on GitHub but not Pavlovia


I’m new to using the Builder and tried creating an experiment that could be run online.

OS : macOS High Sierra version 10.13.6
PsychoPy version : v3.0.2
Standard Standalone? yes
What are you trying to achieve?:
Upload my experiment to Pavlovia for it to show up in my Experiments tab.

What did you try to make it work?:
I created the experiment using the Builder and managed to upload it to Pavlovia’s GitHub, where all the files are showing up correctly. However, when I log into Pavlovia and go to my Experiments tab, this is empty.

What specifically went wrong when you tried that?:
Include pasted full error message if possible. “That didn’t work” is not enough information.

I tried syncing it again from within the Builder with the coder view open in the background and received the following error (the error message seems to cut off at the end):

Welcome to PsychoPy3!
Traceback (most recent call last):
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python3.6/psychopy/app/builder/builder.py”, line 2265, in onPavloviaSync
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python3.6/psychopy/app/builder/builder.py”, line 1682, in fileExport
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python3.6/psychopy/app/builder/builder.py”, line 2241, in generateScript
psyexpCompile.compileScript(infile=self.exp, version=None, outfile=experimentPath)
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python3.6/psychopy/scripts/psyexpCompile.py”, line 51, in compileScript
script = thisExp.writeScript(outfile, target=targetOutput, modular=True)
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python3.6/psychopy/experiment/_experiment.py”, line 238, in writeScript
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python3.6/psychopy/experiment/routine.py”, line 279, in writeEachFrameCodeJS
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python3.6/psychopy/experiment/components/keyboard/init.py”, line 297, in writeFrameCodeJS
“Variables for allowKeys aren’t supported for JS yet”)
psychopy.experiment.utils.CodeGenerationException: Variables for allowKeys aren’t supported for JS yet:

Any ideas would be great, thank you!


Rather than using a variable for the keys which participants could use in my excel file, I specified the 4 keys in the builder. It now shows up on Pavlovia’s Dashboard > Experiments. However, when I change the experiment to pilot and try running it, it gets stuck on “initialising the experiment…”.

The link to the experiment is:

I’ve looked at other similar posts on the forum that recommended checking the JavaScript console, but I’m really out of my depth as to what I’m looking at / for.

Any suggestions would be great!


I tried running the experiment at this link and it failed because it could not find SAM.jpg. See screenshot:

In general, the advice to look at the Javascript console is to use your browser’s web development tools. For example, on Firefox, press F12 or Tools → Web Developer → Web Console, and look for errors in the console output.

Thank you! I ended up being able to open the JS console, but I didn’t really know what I was looking for. In the end, I made a new experiment and sync-ed that again.