Experiment not saving mouse component information

URL of experiment:

Description of the problem:
Hi everyone,

I am making an experiment for a student which tries to recreate the type of aim warmup task used by gamers.
While it runs fine, there are a few issues with the data I get:

  1. Some of the mouse components register as clicked but do not have any data saved in the data file (e.g. mouse.time, which is the most crucial for this experiment) - there’s an example of this in the folder attached below, in the data subfolder.
  2. I have created a list (aimRts) using a code component which saves all the mouse components’ times (this creates a list of lists), and am trying to subset this list with only the non-empty lists (e.g. aimRts = [[0.9768],[2.6497],[2.9345],,], and I am trying to create aimRts2 = [[0.9768],[2.6497],[2.9345]]). I am however having issues with doing this, and wondered if anyone would have insight? I tried code which should work but it doesn’t. This is also dependent on point 1 working, as otherwise I cannot differentiate between missed and clicked targets.

One last feature I’ve tried to implement is ending the routine if a number of targets have been missed in a row (operationalised as N consecutive targets disappearing from the screen before they’ve been clicked). If anyone knows how to implement that I’d be very grateful! I’ve tried a number of solutions from the forum but none seemed to apply.

Thanks in advance!

ben_stroop.zip (5.2 MB)