psychopy.org | Reference | Downloads | Github

Experiment does not sync for all members

URL of experiment: https://gitlab.pavlovia.org/kqlu4156/learning-alternations

Description of the problem: I gave my supervisor Maintainer permissions on my project (through gitlab) so he could pilot the experiment. When we were testing today, I made a minor edit and synced again so we could go through a different part of the experiment, but when he attempted to run it, it still ran the old version. The newest commit did show up on gitlab and I was able to run the newest version through my account using the same pilot token.

Is there anything else I need to do to make sure collaborators can pilot the latest version of my experiment or does it just take longer to sync for collaborators?

Thank you.

Ctrl Shift R to flush the cache and run the latest version

We have tried doing that but it still does not seem to fix the issue of being unable to run the newest version despite the experiment syncing to Gitlab. We have also tried setting the experiment to inactive and back to piloting to see if we could force it to register the changes, but it still does not work.

(The newest version of the experiment is located at https://gitlab.pavlovia.org/Asherov/alternationsd due to some issues making new commits.)

Further update - I tried downloading the code from his copy of the project and syncing it with mine, and both of us were then able to run the experiment with the newest changes. Does this indicate there might be some issue with his account itself?