psychopy.org | Reference | Downloads | Github

Experiment crushes right after it's started

Every time after clicking on the run button I see an usual grey screen of running experiment, but it always end up with a white screen of death even before you’re able to see any stimulus. And the only message i receive in the output window is “pyo version 0.6.6 (uses single precision)”.
I have Windows 7 64 system and tried some versions from 1.85 to 1.83, but what bothers me the most is that about a year ago i had a different hard drive and everything was fine.
Sorry if my question is silly and it will turn out that the answer is simple as pie, but i couldn’t handle this problem by myself.

Hi there,

Have you managed to solve this?

Please could you give a little more detail about what you kind of experiment are trying to run so I could have a think if I could help.

Did you switch between different versions of psychopy or operating systems since you ran this on the hard drive that worked?

Thanks,
Becca

Hi, thanks for your answer.

I’ve tried to run a basic experiment, that is shown in psychopy tutorial on Youtube. But even a test run, that starts when you first time launch psychopy fails in process.
And yeah, I switched between different versions of psychopy and think of installing another version of OS now, may be it will help, so thank you again.

Hi,

Is this the stroop demo ?

Try to run in the original version of psychopy you built it in.

You could also try peeking at the stroop in the “demos” of builder and see if that works - if so check how it is different from yours.

Thanks
Becca

Hi there, I experience a similar problem and as I am new to Psychopy I got stuck quickly:

When launching the demos in Psychopy Builder, the first screen with “Participant-No.” and “Session-No.” appears correctly, afterwards, I get a black screen, when pressing a random button, I white screen follows, nothing else happens and I receive a message that python.exe is not working anymore.

I work on Windows 10, Python 2.7, Psychopy 1.90.2

In Psychopy Coder, there are several error messages depending on the demo, e.g.

ValueError: Attempted relative import in non-package

or

TypeError: unsupported operand type(s) for &: ‘long’ and ‘LP_c_void’
Exception AttributeError: “‘NoneType’ object has no attribute ‘close’” in <bound method Window.del of <psychopy.visual.window.Window object at 0x00000000033330B8>> ignored

Is there a problem with the versions I use or is it rather a hardware problem, maybe due to the graphics board (I use an integrated IntelHD card).

Any help is really appreciated!

Regard,
Charlotte

Hi Charlotte, I’m afraid I’m not going to be very helpful here. But at the moment it seems to me that there’s not enough information here. My guess would be that you’re trying to use a variable in some way using a method that hasn’t been imported into PsychoPy. Bear in mind that I know very little about PsychoPy (you’ll find plenty of novice questions by me around here), so this is little more than a wild guess. It may be that you need to explain a little more about what your experiment should be doing (should it be paused until a button is pressed for instance, or should it just present text straight away, for example?)

Hi,

I am having a similar issue.

I built the task on windows 10, however after an update (which cannot be undone) the task no longer runs to time. We have videos being shown and a rating after each one. Each trial should last 8 seconds however the its taking 9+ seconds to load each video.

We have tried many things but it doesn’t work on any computer now, so we are trying to run on windows 7. However now the task won’t run at all and we get the pyo version 0.6.6 (uses single precision) error.

If you could help with either of these issues I would be very grateful.

Hi Natalie,

Please could you share more about what version of PsychoPy you are using? how long are the videos that are presented?

Thanks,
Becca