Excel does not properly record accuracy and reaction time data (keep getting 0 in corr. column, reaction time is not recorded at all)

Hi everyone!

I am currently doing a reaction time and accuracy task that involves comparing visually presented numerical information and auditory numerical information. The visually presented numerical information will be presented in three forms - Arabic numerals (e.g 5), number words (e.g five), and non-symbolic magnitude (a picture of 5 dots). Both visual numerical information and auditory numerical information will be presented sequentially. After the presentation of the 2nd stimulus, participants are to respond if these two stimuli are conveying the same information or not. They are supposed to press “z” if the numerical information is the same and “/” if it’s different. From here, I intend to record the reaction time and accuracy of the participants’ responses.

However, the problem is that accuracy is always recorded as zero in my excel sheet (see samedifferent.corr). Therefore, I have tried to insert this code into my experiment (as highlighted by the red box in this picture)

With this being said, I’m not sure if this is because of the codes present in lines 523 to 529. A non-response is an incorrect response in my experiment, but I’m not sure how to change this. Deleting that segment and replacing it with the code in the red box resulted in such an error message


With this, my experiment could still run fine. While I managed to obtain a “1” for accuracy in one of the trials, I found that the “1” in that column isn’t encoding the information that I want too. I tried 3 trials and answered accurately on all of them, but only one trial registered a “1” in samedifferent.corr, while the rest recorded a zero. On a side note, I’m not exactly sure why the “/” was recorded as “none” too.

Another problem that I was facing was that in my code (as shown in the first picture), reaction time was supposedly recorded and measured (samedifferent.rt). However, it does not appear in my excel datasheet at all. Is there any way I could work around this (e.g print function)?

I’m not very sure about what I can do moving forward - I’m relatively new to Psychopy too. I’ve checked previous threads on this and have tried to apply the advice from there to my experiment, but it doesn’t really seem to be working too. Maybe I’m applying the information wrongly here. Hence, I would like to ask if there’s any advice on this. Would really appreciate any advice/help on this and sorry for the inconvenience caused!

Well, you’re experiment is clearly (correctly) detecting z keys and calling them correct. Is it just on response= “/” that this goes wrong? Have you specified the “valid key” as being “/” rather than “slash”? You have to use the name of the key, not the character it produces. Hope that makes sense.

Hi Jon!

I have tried doing that, but it doesn’t seem to be recording my answers for trials that require a “/” response.

I ended up using other keys instead for my answers and RT and accuracy are now recorded properly.

Thank you!