Error when running online Pavlovia experiment - unable to flush/upload/save/compress participants logs

jsPsych version (e.g. 7.3.1):
Suddenly, I encountered a problem when running my experiment online. The following error shows at the end of the experiment (when the results should be saved).

My participants enter an ID that consists of only digits and letters.
Some people took the experiment before and there was no such error. It appeared today and I really don’t know what to do.
Please, help!

Same error - any ideas?

Same issue here!

I can replicate this issue using Mac, Chrome browser (Mac with other browsers or other OS seem to work fine; edited: I found some window users experienced this issue too)

It seems like formatting of the exp date includes slash ("/) and it causes the issue when saving the file.

Is there any quick workaround to resolve this issue? Is there anyway I can make logfile not having date information in their filename?

I’m using PsychoJS: 2022.1.2

1 Like

I believe I am having the same issue. Not all of my participants are experiencing it, but quite a few seem to be in the past few hours. One messaged me that they received the same exact error.

I have the same error. My experiment worked for >100 people and now I receive this error.

the same problem with me … any idea to solve it?

This issue is currently in the jspsych area. Are these jspsych issues or are they happening with PsychoPy/PsychoJS? If the latter, please could you edit your posts to include the version?

Hi all - getting this all of a sudden for many of our scripts across multiple accounts. We had a report yesterday afternoon, and when I tested this morning - I had no issues. Then from about 12pm today I started getting the same errors and found it is a problem across pretty much all of our scripts.

I’ve done some tests, and I’ve noticed that for us it is specifically affecting any scripts that are utilizing PSYCHOJS Platform Version 2022.1.3 … Older versions are not affected for us and complete correctly. Attached are two separate examples.

Seems to be an issue with the date formatting suddenly changed to slashes for the log saving. Before “02/16/2023” would have been represented by “02-16-2023”. So, it seems to be something has broke on the server side for that version, though not sure if any other versions are affected.

I think this needs escalating if possible, as there are a number of live studies affected by this at the moment. Although data is actually saving, for scripts that rely on redirects afterwards - this is now breaking.


I’m currently experiencing the same issue with scripts using PsychoJS 2022.1.4.

I’m adding a link to this post since it seems to be connected.

Thanks. In our testing of log saving at session end:
:white_check_mark: success with Safari, Opera, Firefox, and Windows Chrome
:x: failure with Edge and macOS Chrome

Hi all, I am using version v2021.2.2 and it crashes for me when trying to compile the log file into .gz – probably because of the same change of using ‘/’ instead of ‘-’ for the date format.
However, as many mentioned, this error does not occur for all participants.
The csv file is saved, but it is not possible to redirect to other platforms, hence crashes.

I wondered, could we get around it by simply not saving logs and instead only .csv files? Obviously, this might only be a temporary solution…


you are right. This is an experiment made in PsychoPy builder and sent to Pavlovia, so it is PsychoJs. Platform version is 2022.1.1
Unfortunately, I cannot edit the post and tags anymore.
Bugs are still appearing. How can we fix the problem?

Good morning,

As @fgasking mentioned, the issue has to do with the date being formatted with / instead of - for those particular participants’ sessions.
This is exceedingly odd as no recent changes were made to those versions of the PsychoJS libraries or to the server code.
I am investigating what the matter is, which I suspect has to do with recent updates to particular browsers (i.e. Edge and macOS Chrome: thank you @denispelli !) affecting how they are handling dates, and especially locales. I am glad it only affected logs.
In the mean time, I have sorted the issue on the server side, so it should not affect any participant at all, moving forward.
With my apologies for the inconvenience,


Hi Alain,

thanks for the information.
Just to understand this correctly: we are now able to launch our studies in a normal way, also saving log files and the compressed .gz logfiles?
Or do you means, if we do not save log files but only csv files instead, it will run properly?


Hello Nadesha,

You are welcome to run your experiments as normal.
I have tackled that particular issue on the server side: should the experiment specify a name with the dates containing /, the server will change those / to -.
Best wishes,


Thanks very much @apitiot for resolving - really appreciated. Tested again and I can confirm its all now working from our end.

Just to note though - we had the issue also with Windows Chrome on Windows 10. What was odd, was that it was failing for one of our users one evening, but worked fine for me in the morning - then started playing up in the afternoon. Might have been a caching issue potentially.